Running a job hangs after about 11 lines sent

I’m new to this software and I am coming from the Universal gCode Sender application. I am using a Mac and gSender now and it connects to my home made CNC using an Arduino / GRBL system. Jogging works perfectly. But when I run the job, it proceeds to move the tool to the correct starting point on the material, starts the router fine and then proceeds a few millimeters (less than 5) and everything stops. I see in the console window that more commands are being sent but my system does nothing. It indicates that anywhere from 11 to 20 lines have been sent and it just seems to hang then. gSender does not seem to indicate any Idle status. Not sure where to go form here. Does anyone had any ideas on where to start looking? Any more information you need to help me diagnose this issue? Thanks.

I had a problem a bit similar to this. Solved by putting a USB hub between Mac and Arduino to solve obscure compatibility issue. Likely not your problem, but you never know