Setup a homebuild machine?

Hi guys.

I wanted to try gsender, but I ran into a situation. I can connect allright on com 3 as usual, but i cant jog at all. When goin to the setup area, theres these machine presets. But my machine is homemade GRBL. How do I get it to work?

Hope you can help me out, because this software looks way more nice than UGS…


Hi Thomas :slight_smile:


Who’s controller do you have??


I have a home-brew controller (grbl-HAL based) and have to issue a command in the gSender console to get the two to recognise each other - I use “$RST=&” without the speech marks. Without this gSender doesn’t get what it needs from Grbl and so sits there patiently waiting (I presume a Grbl 1.1 or 0.9 controller auto-sends something upon connect, but I haven’t worked out what that is to set it up).
Like you I much prefer the gSender UI and philosophy versus Carbide Motion (that came with my ShapeOKO when new/stock and I find to proscriptive/nanny-state), or UGS which seems to have lost development energy/direction (I contributed to code development on UGS but after 8 months of unapproved or unrejected code pull requests, I have given up on using it). Their bad luck as finding gSender has for me been a better move anyway.

My machine is just with an Arduino board, so I don’t know how to tell gsender what machine it is? Also the work area… But main issue is still the jogging, it won’t move? But i can connect and start a job, so there is a connection… :smirk:

The Arduino, when running Grbl, auto-responds to any Sender app and declares which version of Grbl it is running, and subsequently data about max XYZ and current offsets etc. Grbl 0.9 had a simple jog command mechanism which was improved with the “$J” commands in Grbl 1.1f. It is possible, describing as you have that the machine does ‘sort of work’, that gSender is assuming $J for jogging but your Arduino/Grbl setup doesn’t recognise that.
At the Console (tab in gSender) type in “$I” without the speech marks, followed by the Enter key, and the Arduino will respond by telling you what version it is. For example, my machine responds with:
[AUX IO:4,3,0,0]

If my %J hunch is right, I think the [VER:xxx] line from yours will say 0.9 at the start, which doesn’t understand the newer %J jogging. What to do about it… I can’t see a setting in gSender that says ‘use old or new jogging commands’. Do you believe it would be possible to upgrade the Arduino to the later/latest V1.1f Grbl? I appreciate this isn’t everyone’s knowledge area, however.

Someone else can chime in here if I have headed down the wrong rabbit-hole… I am aware I’ve taken a hunch and made a whole subject out of it…