SLB Ethernet connection issues

This is the standard template you can use when posting about an SLB / firmware problem. If at all possible, before posting an issue, see if you have the most up-to-date version of gSender and of the SLB firmware. If you don’t, see if you can get the latest versions (firmware and gSender) and repeat the same problem again: it may be possible that the problem you’ve found may have already been solved. If you’re on the latest version and you still see the problem the definitely let us know!
:arrow_up: Delete this when you make your own post :arrow_up:

  1. Firmware version: Unknown?
  2. Sender: gSender 1.4.6

Steps to reproduce:

  1. Connect to SLB with Ethernet
  2. Close gSender without disconnecting
  3. Open gSender and try to reconnect Ethernet

If you turn off the SLB and turn on, you can connect but it appears that the SLB doesn’t drop/disconnect the old session so closing gSender and re-opening cannot reconnect.

@hamanjam FWIW, Jim, I just followed your 3 steps and I can re-connect the ethernet connection every time. How are you connecting? Are you connecting directly from the PC to the SLB or are you going through a router?

I’m going directly to the SLB. I saw the same issue helping someone in Zoom the other night and they were seeing the same thing. I can grab a video later if that helps

Hopefully this works and it’s as I’m describing it

SLB Ethernet Connection

FYI I’m having the same problem.

@hamanjam Sorry for the delay in replying, Jim. I watched the video and I am a bit confused by the ip addresses. I won’t be able to get to my machine until this evening. Then I can compare my numbers with yours and get back to you.

I just noticed that when I double click to stop the endless connection process using IP and then exit Gsender it executes Homing twice. ( I had clicked the Homing button twice just for grins). It’s Like it cached the attempts. Weird

@hamanjam This will be one for tech support. I’m curious. If you disconnect before closing gSender, then close gSender and open it, can you connect?

FWIW, there are a couple of differences between your settings and mine. I used the default address for mine 192.158.5.1, and set the card to 192.128.5.5. You have used 192.168.6.1. I’m not saying that makes any difference. It’s just an observation. The other difference between your setup and mine is that you have set up remote access using an ip address. I don’t have remote access enabled.

If you don’t mind another question, what are your settings for $301, 302, 303 and 304?

I’m sure that tech support will be able to address this. I suggest that you open a support ticket.

Just to clarify, my home network is 192.168.5.x on the first Ethernet adapter so I put the Longmill on 192.168.6.1 on the second standalone adapter. I keep a separate connection between the gsender machine and LongMill just to avoid any latency issues (I am a Technical Architect by day so I have a lot of servers on the network and multiple VLANs so best to keep separate)

MiniPC running gSender:

Ethernet adapter 1 = 192.168.5.47 (Connected to Ethernet switch to rest of network)
Netmask=255.255.255.0
Gateway=192.168.5.1
gSender Remote: 192.168.5.47:8000 (Not really used because I RDP into machine)

Ethernet adapter 2 = 192.168.6.2 (Connected directly to SLB)
Netmask=255.255.255.0

Firmware settings:
300 = grblHAL
301= Static
302=192.168.6.1
303=192.168.6.1
304=255.255.255.0
305=23
307=80
308=21

@hamanjam I would think that there is enough here now for Sienci to be able to look into the issue, Jim.

Just for my education, if you don’t mind, if you disconnect before closing gSender, can you then re-open gSender and re-connect. Or, do you still need to power cycle the SLB?

I thought it would reconnect if I disconnected first, but it doesn’t appear to. I disconnected and left it for about two hours and when I came back, it’s not connecting. I’m installing wireshark to see if I can scan the adapter to see if anything is happening and I’ll open a case with support

@hamanjam Tks for that, Jim. It will be interesting to see what it works out to be. I played again this pm and can’t duplicate it no matter what order I do things in.

If everyone with SLB upgrades to gSender 1.4.7 they will get locked out when the newer gSener boots up. Like you mentioned, one has to power off the SLB first.

I came across that when I upgraded. I opened a case through the support email and I’ll update the thread as anything changes.

I noticed today that if I uncheck “reconnect automatically” and then restart gsender, I can connect without rebooting the SLB. Watching wireshark packet traces, I see where the SLB sends an “RST” back to gSender along with the firmware settings but maybe gSender isn’t ready just yet so it can’t process. Unchecking the reconnect gives it enough time to come fully up so when I connect, it is all in sync.

1 Like

That’s a good find! Perhaps we’re decently teed up now to find a resolution here Jim :grinning:

EDIT MAY 16: still a work in progress on testing and finding the source. Will update when I have more news to share