Soft Limit Problem (I think)

Newbie here. I have a Gemistu 4040PRO and I am running gsender. Everything setup up quick and easy and manage to get a couple small projects off quickly. But I’ve noticed a slight problem and not sure how to resolve. The machine is supposed to be 400mm x 400mm and when I set up the firmware I selected the Sainsmart option and it populated things accordingly (I believe).
My problem is if I home the machine and rezero everything, and then I send the machine to the max position (upper right button) it will only go to 380 / 380. I can manually jog it to 400 / 430 actually before it touches the hard limits. I’m thinking there is something limiting my travel but not sure what to adjust.
Any help is greatly appreciated. Cheers!!!

The devs have stated on here before that those buttons just bring it to the general area not exactly to the limit so I think your OK. As long as the machine will jog to the limits I believe it should cut to those same limits.

On a side note I think that’s the same machine my step Dad has and it has limit switches at both ends of each axis. If it does have limit switches at both ends you don’t even need soft limits enabled just hard limits and homing.

Thanks for the support.
Yah I haven’t done a project of that size yet so it hasn’t been an issue. I do have a project planned for the max size so we will see what happens then. Probably worrying about nothing.

You could always set up a test cut like a rectangle 395x425 or so and set the Z high so it “cuts” air to test it out before doing that large project. Just a thought because it would be a shame to mess up a really big piece of material.

Yah that’s a good idea. I always use the Outline feature just to make sure things are located properly on the workpiece - the small laser I have had this feature and it saves a lot of guessing.