"Start at G-code line" does not turn spindle on

Well, I made it through 20K of a 28K line code and broke a bit. Went to start from gcode line 20K, axes started moving through the sequence but the spindle never turns on. I’ve tried this on both gSender 1.1.17 and edge 1.2.4 to no avail. Also noticed I can’t use the M03 code in console to start the spindle manually, anyone know why that is? I have reset control board, gsender, reinstalled, even threw a wrench at one of my kids for good measure but still nothing. Any suggestions guys?

Hi spindle (router) power and rpm are controlled by the user.
M03, M05 and M06 are inactive.

1 Like

@Andy1 Controlled by the user how? I thought the function of “start at gcode line…” was to pick up from a user designated line in the code then adding a start sequence and a few lines of the preceding code. I just looked at console and noticed the following start sequence (see below), note the S0, why would it choose 0 as the spindle speed when the rest of the file is set to 12,000?

feeder G0 G90 G21 Z25
feeder G0 G90 G21 X-8.524 Y-18.754
feeder G0 G90 G21 Z-6.250
feeder G21 G90 G91.1 G54 G17 M3
feeder F400 S0
feeder G1
feeder G4 P1
feeder M03
X-8.957 Y-18.879
X-9.023 Y-18.897
X-9.094 Y-18.913
X-9.522 Y-19.004
X-9.563 Y-19.013
X-9.594 Y-19.019
X-9.665 Y-19.029

I am assuming you have a makita router or the like. The spindle cannot turn on unless you turn it on. It cannot set Speed unless its already set by you. When you broke the bit did you not physically have to turn the router off?

The big question seems to be if your machine uses a spindle or a trim router. A lot of us have LongMills with a trim router that you have to manually turn on/off and set the speed manually.

As this is the gSender category I won’t make any assumptions about your machine. If you do have a spindle then this might be a bug. Can you tell us what kind of machine you have or confirm that you do have a spindle that uses M3, M4, and M5 to control with S for speed.

Did you mean M3, M4, and M5? M6 is tool change.

1 Like

@_Michael @Andy1 I have a 500w spindle, not a router. Yes, the spindle is controlled via gSender by M commands, hence the reason I pointed out the “S0” in my previous post. I found a workaround but it’s a pain in the ass and probably not very wise. I agree this is probably just a bug but can’t for the life of me figure out why it just started happening. I’ve run the “start at” function a handful of times within the last week without issue.

Slightly off subject but… why do you guys manually turn your routers on/off? Can you not simply have M3/M5 trigger a 110v relay for that? I’m assuming the DC spindle output could handle that?

I do have a relay for mine so it can turn on and off, it controls my dust vacuum too, still have to manually set the speed though.

I have never tried the start from line so I’m probably not much help. I mainly jumped in just to clarify if you indeed had a spindle. Should help others to help you.


My assumptions were based on the default. I do not have a spindle on this machine, I have a router which I must turn off and on manually and adjust for speed manually. I do have a clicker for my vacuum.

I don’t know but i’m sure someone here will know how to accomplish this.

So when I pause ; the machine does its thing , however I still must turn the router off to change a broken bit and since im usually in the middle of a job when this happens so I leave the speed control on the router alone.

I can see how a spindle would add complexity to this operation.

1 Like