Trying for first carve


I’m a total newby - trying to do my first carve.

I have my 30x30 Longmill assembled. I installed UGS. I created a small test project and saved it to a .nc file. (that’s “Gcode”, right?) I bought the T-tracks, hold-downs and touch plate. I secure the first piece of pine. I have jogging working in three axes. I put a 1/8" flat endmill with the collet sleeve in the router.

I put the touch plate on the lower left side of the blank. There is a default setting of 10mm for height of touch plate. I measure .580" which is about 14.7mm. Do I put 15 in that field?

I jog the bit to about a quarter inch above the touch plate and inside the corner on the X and Y axes. I find the Probe Module plugin. I click “Initiate Probe”. Then the router moves up, not down, and throws an error after moving a bit more than a half inch.

Do I have my z Motor wired backwards somehow?


-Mike M

P.S. Here’s a pic which might help:

What happens if your jogging the machine? So does the router goes down when pressing the z- button in UGS?

If it is moving up instead of down, then it is a ‘problem’ of wiring or the grbl setttings (P1).

If its going down as supposed, the problem is somewhere located in the touchplate settings (P2)

(P1): Cables of the z-motor could be permuted (check the color order of the z-cabels) or the grbl setting $3 could be wrong (think it should be 5).

(P2): Carefully check all probe settings provided within the installation instructions.

Thanks JHahn for the quick reply.

Yes, z- sends the router down.

I found the setting Probe Module => Z => Probe Distance/Direction. That setting was at 10, so I tried -10. Now when I click Initiate Probe, the router goes down.

But, the bit hit the touch plate and kept on going. Luckily no damage was done. I checked the continuity of the probe by putting an ohm meter on the two contacts. When the bit touched the touch plate, the resistance went from infinite to just a couple of ohms. The cable is plugged in the right socket. Why would the probe not stop the router from going down when contact is made?


-Mike M

I agree, that shouldn’t happen. Think you should check if this problem is mechanically or software related.

Therefore, I suggest to test the probe module by hand. If i remember correctly, UGS shows on the lower left corner if an interrupt (limit switch/ probe/ etc.) is triggered. So just connect the probe and the magnetic part by hand and see if UGS recognizes the activation (so without starting the probing routine).
If yes, bend/shake the cable by hand, maybe there is a lose contact. If it is allright, then start a z-probing (with router high in the air) and see if it gets interrupted when pushing both parts of the probe module together.

@JHahn, thanks again for the input. Shorting the magnetic contact and touch plate by hand neither put any output to the console, nor interrupted a probe seek. :frowning:

Is there anything to read on the Probe/GND contacts at the control board? Thought I might find 12V DC, but nothing. Maybe it is just looking for open/short?


-Mike M

@mike99mac Mike: In addition to @JHahn/ Jannik’s advice, I’ll throw in a plug for gSender. Using the probe module in gSender forces you to test the contact between the bit and the plate before you run the module, thereby eliminating the possibility of crashing the bit into the plate. If you see no connectivity during the test, you can start looking for the source of the problem. I would suggest starting with ensuring that the connection in the banana plug is secure.

I agree with Grant.

Btw. I cant reproduce this, I am confused… obviously false memories…
However the probing cycle should stop…

Thanks to all who replied. I got the probing working with gsender. It took me a while to get that installed and set up, but I already like it more than UGS.

In the end the problem was probably that I did not have good connections on the green two prong connector. I may have put the wires on the wrong side so I had to turn the screws counter-clockwise to “tighten”. When I put the wires on the other side of the contacts and really tightened the screws clockwise, the connections were not intermittent.

But this mistake gave me the impetus to install gsender, so it all worked out OK.

-Mike M
1 Like