Typo, correction, and borked probe settings

I have a brand-spanking new longmill; I set it up, used my probe a few times and everything was going fine.

Then I tried adding a laser, and I fat fingered $32=1 and $32=0 and accidentally set $3=0

That revealed itself very quickly, I noted my error, and after some digging I found the correct value and set $3=5.

BUT - ever since then, my probe now does something odd: it probes z fine… then moves left to prepare to probe X, but then it doesn’t move Z down (so, of course, it misses the touch plate and throws a system fault).

Did setting $3=0 jack up another setting that I’m unaware of, and if so, what is it?

@dgl3906464 Welcome, Daniel. When you enter $$ into the console, is the $3 value 5?

Jog control works fine, and I can run programs fine if I zero the machine manually.
But probe (which worked fine prior) doesn’t lower z before checking x (even after checking z successfully)

For anyone interested: I just blew away UGS and reinstalled from scratch, and it fixed the issue. I prefer knowing WHY, but at least I’ve got a working touch plate again.