UGS error code 2


I have been running the same g code file through UGS for a few months now to make cribbage boards. I have done about 15-20 boards with no issues so far. I run one file for the lines, one file for the text and one file for the holes. on my latest board, the cnc kept pausing after a few minutes. when i hit play it would resume and keep going for a few minutes and then pause again. However on one of the times i hit play, the router never raised before moving over to the next hole and carved a line across the board and ruined it. I tried again on another board and it gets to about the same spot and stops. I checked another file that i have for shallower holes and it does the same thing. The lines and text files work fine. I took a picture of the console window in UGS of the error when it pauses (sorry about the blurry photo). Has anyone else seen this error?

At first i thought it was the controller as my power input is a bit janky. I had emailed Andy about it awhile back and he just told me to check the connection wires. The set screw on the green plug in can come loose at times and i periodically have to tighten it. The connection into the board itself seems loose as well as when its plugged in, the connection is a bit loose and the lights go in and out until i find the right sweet spot. This may be a side issue but i was able to run other files just fine, its just when i run the holes file that it pauses.

Can g code files go bad or anything? Strange that i have run it over and over with no issue and now its suddenly not working. I created the file in carbide create. I will test generating the gcode again to see if it fixes itself but thought id ask here first.


@amrdesignyyc The short answer to your question about gcode going bad is No. :slightly_smiling_face:

So, something else is going on. The most obvious place to start is hardware, since you have run this same file successfully. You mention that the set screw on one of the green plugs comes loose from time to time. Are the ends of the wires in that plug still tinned? If they are, I recommend that you cut off the tinned part of the wire, strip back the insulation and put the bare wire into the plug. You may want to do that with all of the motor wires. This was talked about some time ago on this forum.

As to the power input being a bit “janky”, do you mean that the jack from the power supply to the controller is loose fitting?

1 Like

Thanks for the info Grant. My wires were still indeed tinned. I snipped those off and reconnected it, which seems like more of a stable connection. I also downloaded Gsender and the file seems to work fine now. I think the wiring issue seemed to solve it but perhaps the software is helping as well.

As for the janky connection, yes the green connector that the wires fit into seems loose when its plugged into the controller. i can “pivot” the entire connection up and down about 1/8" of an inch or more. The wires themselves are secure but the green connector and the female port inside seem loose. I took a video but cant upload it to here.

@amrdesignyyc Well, Andrew, I’m glad that you got things to work. I misunderstood which plug was “janky”. Clearly, we can’t fix that - you and me - going back and forth here. I’m sure that Sienci support will help if you need it.