Ugs not loading

ugs will not load. loads half way then vanishes have uninstalled java then reinstalled still get the same thing. running windows 10. was working fine till today

I had something similar happen. Have you ever had it start? If not, double check that you downloaded UGS Platform and not the other UGS. I had the same symptom with the regular UGS.

I recently had that issue too. Some other programs wouldn’t run but some would. I ended up downloading Win 10 Home again and re-installing. That fixed the problem. Thank goodness the only things I had installed was UGS and CNCjs. I was thinking it was my hard drive was messed up but since others are having problems I’m wondering if it is maybe a Windows problem.

@tjlang Ted: Since it did work, it may be an idea to check in task manager to see if windows thinks it’s running. It may be hiding in the background. Just in case this is new to you, press ctrl-alt-delete and select task manager from the drop down list. Open it and check processes.
That said, what version of UGS are you running?

Heyward, do you like CNCjs? So far I’m not loving UGS. On the upside, I like the embedded visualizer a lot, on the downside, I find the button sizes very small and the navigation approach for jogging the system not as intuitive as that on the ShopBot I was used to. I’m thinking about trying a different platform but I’ll need to upgrade my firmware to use CNCjs. How would you rate it?


Jeff, so far I like CNCjs. In my testing at this point I have not had any issues like stopping/not restarting, not jogging, etc. It’s very similar to UGS but there are a few things I’m not liking. There is HELP but it is very limited. Explains what function is but doesn’t tell you how to use them. I have not found a return to zero button yet. I need it. There is a probe widget but you have to do X Y Z separately. I did find a “Macro” for XYZ probing but haven’t tested it since I haven’t figured out what measurements to put where. There is a visualizer that works good. You can view the cutout from all sides and 3d. You can zoom in and out. There is a pendant setup but it is rather involved so I’m not into node.js programming. So I’m using a mini wireless keyboard with touch pad mouse. I’m still testing and researching for more info but it looks good so far.

I didn’t have to upgrade the firmware to run CNCjs. The latest version of CNCjs fixed the “Name” issue. I just downloaded, installed and ran it - on Windows 10 that is. I also made my own Return To Zero macro so that problem is solved. The “Macro” is nothing but a text file with GRBL commands. Simple. I set up a separate macro for XYZ probing for each bit size rather than having to update bit diameter each time.

Excellent, thanks for the info. I have a wireless handheld keyboard with arrow buttons sitting here waiting for me to look up the post about how to map it to UGS. I will feel better making the space bar “stop” and having it with me. Side stepping to the laptop if something goes haywire is uncomfortable. :slight_smile:

1 Like

well after doing reinstall of windows 10 its still doing the same thing.

What version of UGS are you running? You may want to try the most recent nightly build.

2.0 platform august 14,2019

Where did you get your copy of Windows? I downloaded from Microsoft directly.

yes about mouth ago then i reinstalled today ugs had been working till this morning
when out to start a job

the nightly build doing same loads half way then vanishes

That’s what mine was doing. Re-installing Win 10 Home fixed it for me. I just did mine 3 days ago. Maybe I downloaded a later version than you. Just guessing at this point.

it seems that java and ugs are not connecting is there setting that will prevent that

Somewhere in UGS modules you can specify where Java is located. I’m not sure where to look. I guess in the UGS libraries obviously (Duh). Lol. I’ll do some looking and see what I can find. I know it’s been posted on the forum or FB but not sure what to search for. JAVA maybe?

ok i was thinking it was java security setting

Ok. I found this on facebook in the longmill group -

You have to tell UGS64 where Java is located by editing the ugsplatform.conf file in notepad. That file is in the “etc” folder. Edit the line near the bottom that says jdkhome= and enter the path to the jre file location in quotes. The entry I have is “C:\Program Files (x86)\Java\jre.8.0_241”. Your location may vary depending on the version you installed. Otherwise just run the ugsplatform.exe file.

I think you have to remove the # also but not sure. Try it with the # and if it doesn’t work remove the # and try it.

i tired this and its still only loading half way.