UGS Platform issues

That’s what worked for me. Downloaded the latest version from Microsoft.

I give up, Brad. :slightly_smiling_face:

When/if you do re-install windows 10, be sure to get the latest USB 3.0 drivers. Old ones can cause grief and MS frequently does not install the proper ones for whatever hardware is driving your ports.

latest update: I reinstalled the latest version of Windows 10 (1909) and reinstalled ugs platform, Arduino drivers, Java 8 for 64bit windows and still no joy. Windows does not acknowledge that the Longmill controller is connected, I’ve tried 5 different cables at this point that I know are fully functional. As an experiment I connected a Arduino Uno R3 board to the laptop and it acknowledged it’s connection on com3. It makes a funky little sound each time it is removed or connected. When this board is attached it shows up in the USB page of the settings menu as connected. The Longmill controller on the other hand does not appear in that list nor does it make any sound once connected to the laptop. Maybe my controller is the problem, but its lights all work. I’ve run out of ideas as to how to proceed. If anyone has any ideas please let me know.

@Br5d Brad: I’m being obvious again, but the only step that I can think of now would be to connect the controller to a different pc, with everything that is needed installed. If that does not work, I would conclude that your controller is bad.

Well I just tried to connect with a couple of old laptops and no go, the longmill doesn’t show up as connected nor does it connect in ugs.

I’ll wait to see what Andy suggests and take it from there!

Thanks all !!

the struggle is REAL!

@Br5d Brad: I’m sure that andy will take care of you. I seem to recall another guy here having issues and they were solved by following the instructions on the Sienci main site to set up the controller manually - flashing the board, setting up grbl, etc. That may be a step for you to try. As I recall, the first thing you do is wipe any previous setups, then start from scratch.

1 Like

Success at last, thanks to Andy’s perseverance the Longmill is back up and running. The balance of lockdown will be far more productive now. Turns out the Uno board had stopped working, Andy flashed another that I had laying about and I’m back in Business.

Its a real pleasure to deal with the folks at Sienci I have to say. The quick, efficient, professional and needless to say friendly service is second to none.


Thanks for the reply Bill.
Since I read your reply, I did find that my z axis motor control connection was loose. That solved a bunch of stuff. Although, i still had trouble.
I had some contact with F360 people. They Identified some of the troubles I been having as Post Processing issues. I’ve been reading your posts and found some important tid bits that were helpful (disabling the G28 and M6).

Seems like the Post is placing the first set of coordinates after the retract command. I’ve been able to cut and paste my way out of it. This example below is how the Gcode is right out of post. I paste that line G0 below the Z0.6 and all is well.

G0 X1.7395 Y0.4745

If you have an alternate Post I could use I would be so greatfull.

@Monsieur I don’t use fusion360 and I don’t know which post you are using, but maybe these will help.

Thank you sir. I will give that a go today. I appreciate the help.

@Monsieur Bill’s offer is, no doubt, the way to go.

@BillKorn Hey, I tried a DM but I got denied. “I can not message this user”
Any idea why. Probably my rookie status is my guess.

Hey Bill, what’s the extension of the file for the post? Perhaps I can enable you to attach it directly onto the forum

Chris, the filename is Seth’s F360 GRBL.cps. It has to be renamed to grbl.cps to use it, so I thought about adding .txt to the name so it would upload, and then whoever uses it could also strip off the .txt.

That seems like it would be an good solution :+1:

Chris, here’s are the file and directions:

Seth’s F360 (23.7 KB)

Rename the file grbl.cps. Make sure to delete the extension .nc.

The file has to be put in a specific folder where Fusion 360 gets its run info. Go to the folder c:\users\yourpcname\AppData\Local\Autodesk\webdeploy\production. You may have to enable viewing hidden folders to find the AppData folder. Sort by Date Modified and find the newest folder with the 40-character name like 5d5b542f5ddb82dac8b734aa2cb375dc33c4efb2. In that folder go to Applications\CAM360\Data\Posts. Rename the file there so you can find it later if you want to go back, and put the new one here. Important - Re-start F360. You should be good.

You can make UGS ignore other G & M codes by clicking on Tools, Options, UGS, Controller Options, and enabling the pattern removal of the codes at the bottom.

Good luck. Have fun.


1 Like

I got it all installed. Everything seems to be on the up and up. Thank you @BillKorn

1 Like

Glad it worked out. There are some head-scratchers from time to time, but all-in-all UGS seems to work well with the gcode F360 generates.


Just a note on installing this - you can have F360 import it, rather than trying to figure out a directory to copy it into.

In F360, go into Manufacture. Then Manage -> Machine Library

Under User Library/Local, select the machine that you use. At this point, your should see a something like this:

Click on the folder icon next to the “Post” line, and you’ll be able to import a post processor, which can then be selected for the machine.

Prior to importing the post, I found it helpful to edit the description in the Seth file (on line 13) so I could differentiate it from the default grbl post.

I’ve not had any issues with the default grbl post, once I disabled M6 and set the retract to Clearance. But I will try this one next time I mill something.

1 Like

Mark, good catch. It’s much easier, but it only works if you went to the trouble of creating the new machine, and it’s such a pain I stick with the generic 3-axis mill. Fusion remembers which post you use and the options you select & deselect.