UGS went in to HOLD

I was recently running a job and in the middle of it UGS went in to HOLD. It happened on two different tool paths. I tried to resume but the machine cut where it should not have. Happily, and for the first time, both errors resulted in the mistakes happening in offcut areas of the project so I was able to recover.

Re-running the toolpath worked fine the second time. I wasn’t able to get a clear explanation of what would trigger a HOLD alarm on UGS. Can anyone provide any insight? Given that it ran fine a second time I’m guessing it’s a transient/static electricity or interference kind of thing typically?


@jwoody18 I was getting holds with previous versions of UGS and un-grounded dust collection piping. I’m not sure which fix solved the problem, but I lean toward it being the dust collection issue. There is a whole lot of static created by all that air rushing through pipes and hoses. From what I’ve read, CNC systems like ours hate static “noise”.

I was wondering if that might be it. I need to look up how to properly ground my hose I guess. I assume I just need a conductor wire and a place to tie in to ground? Do you coil the ground line around the hose and how do you terminate the end at the CNC?

My dust collection system has a rigid pvc pipe and a flex hose with a steel wire inside it. I wrapped bare copper wire around the rigid pipe and anchored it to the pipe with a sheet metal screw. This is the wire:

I ran a wire from the wire that is inside the flex hose to that sheet metal screw, too. The other end of the copper wire is connected to plug with all but the ground terminal cut off. I plug that into the power bar that is powering the controller and my router. That power bar is grounded normally.

I had frequent issues with UGS and the Mill before I grounded everything this way. I’ve had no problems since.