Unable To Connect To GSender

I’ve tried everything from uninstalling, unplugging and rebooting and I can’t connect to gSender. What’s odd is, when I remove the USB cable from my laptop, I hear humming sounds coming from my motors, when I plug it back in, the sound goes away.

When you plug the USB cable into you laptop does it make the ding dongs that indicate a USB device has been plugged in? Of course the LM controller would have to be plugged in. Just wondering if you laptop recognizes there is something there.

Not sure what the humming means.

1 Like

Geez, like the sound if I plugged my iPhone into a charger? I don’t recall that sound, but I don’t recall hearing it when I didn’t have issues.

I do have the Motor humming sound:

  • Momentarly, when i reboot the computer/Laptop
  • Constant, if the Longboard is powered on with no USB plugged in
  • Constant, if the Longboard is connected to USB but Computer/Laptop is powered down.

I do not know if it related to the way the Longboard/Motor controllers behaves when Arduino is not powered by USB.
I do not know if this is a bad thing if it was left like that for a while.

Yup If it’s a windows PC when you plug in a USB device it plays a few notes and, usually, something pops up in the lower right corner. If would at least be a good indication that the LM controller was alive.

so Curious question, when you start Gsender, what are you seeing in the console window?

I am curious if the port speed is the issue, or if its just got setting so low, any movement is almost not noticeable
.

another thing to look at, is in the Bios, make sure you have all your USB Ports set to legacy and and or enabled.

I assume you have tried moving from port to port.

do you have a second PC to plug into it?

I would like to see a picture of the dropdown in GSender to see if its even detecting any ports.

Ok so, the “blue” USB cable that came with my Longmill is in fact recognized by my laptop. I get the 2 toned sounds when I plug it in, however, when I go to the “connect machine” button, there isn’t a detected device.

I am not sure which OS your running, so I am going to assume Windows 10,

can you screen grab what your Device Manager says?

I suspect there is going to be an error or something with a !

You can click on the START menu, and type Device Manager
any hardware that needs software will have a !

so you might need to download some drivers from the laptop site, but for now, If you could see a picture, maybe it will shed some light,

if its not a PC, I wont be able to help much.

(this is what mine looks like)

1 Like

thanks, but thats not enough information for me.

can you post a picture of the device manager list like my post?

Your PC will have a bunch of USB ports, its hard to say if that one is the one.

I guess a good start is to show the device list. then unplug the usb able. see which port shows up and removes.

All this to say, if your having this kind of problem, maybe just call Sienci directly on the phone, and they will go through interactively with you on the phone.

Most likely, there will be a lot of back and forth, and if your on the forums, it might take all day, which is fine. but I think at this point, being stuck at the beginning could be resolved with a phone call.

1 Like

When I remove the USB cord, the COM3 goes away. I tried to update the driver, but it’s says I’m current.

I think I feel more comfortable telling you to reach out to sienci themselves.

What your describing makes sense and sounds like it should be working, however I have the Arduino Uno showing up and closing out when I do it.

I also have “https://www.arduino.cc/en/software” installed on both my machines, so I might be seeing more then you.

I dont know how comfortable you are with doing this, so I will say Think about it.

But if you did the following, you might get further

using the " Flashing GRBL using the Arduino IDE"

basically, it will have you re-upload the firmware to your UNO, using the arduino software. I have done it a few times and its pretty easy. But I work on PC’s for a living, so I might be a bit more comfortable

if you successfully are able to re-flash the firmware. It should work, short of a hardware problem.

I will add the following.

At the core of the Longmill is a Arduino Uno, if all you had plugged in is a Arduino UNO, with the right firmware, you will be able to plug it in and connect to it using gSender.

ignoring ALL of the hardware all you need to make connectivity is the Arduino.

I have my Longmill setup in the garage, with all the servo motors and what not connected to it.

However, in my Office, I have a 4 ft USB cable and the Arduino board and I can load and run gcode files to prove its all working. (see picture)

So, what your describing to me, is a problem where your PC wont talk to the arduino.

So its POSSIBLE its the firmware on your machine.
or
its the laptop itself.

if your able to connect to the arduino, wipe and reload the firmware as per their document, you should be off to the races.

Why all of a sudden am I having these issues with gSender? I like using it because of the user friendly features. I’m “almost” considering going to a different software.

Kevin, I agree with Stephen. You might try reloading the GRBL Firmware on the LM controller using Arduino IDE. I had to do this the other day for a different reason. I had installed the new limit switches and tried to update the GRBL Firmware using Gsender and it failed and left the LM controller pretty much in the state you have described. I recovered.

The other thing you might try is using UGS, just to make sure it’s not something with Gsender, although that it doubtful at this point.

I cant tell you why all of a sudden for you.

but I know I have messed up my arduino a few times because I saved a setting and I didnt close out properly.

for lack of a better way of saying it, I bricked it.

Then using the Arduino software, I re-installed the firmware and off it went.

There have been a few people that upgraded the firmware in gSender and it didnt stick, ether there was a hickup in the upload or they shutdown too soon, power spike …

1 Like