Version 1.4 issue

running hp laptop with windows 11 version 10.0.22621. Upgraded gSender from 1.2.2 to 1.4. Connected to longboard found none of the jog buttons worked. I first checked the firmware settings and all looked OK. I rebooted laptop and restarted gSender, again no jog control. I noticed in the console panel 4 error #2 (I think) unrecognized format. I restarted gSender and during connection everything seemed OK then got the four errors again. I reset firmware to default but same issue. Uninstalled gSender and redownload version 1.4. Got the same issue bootup sequence looked good but ended with 4 #2 errors. This time when I checked firmware settings there was nothing there. For some reason I did not make a copy, attached is a copy of the firmware setting before I reset to default. I deleted version 1.4 and installed version 1.2.2 everything works correctly.
gSender-firmware-1_25_2024-1_10_56 PM.txt (562 Bytes)

1 Like

diagnostics_1-25-2024_12-51-24.pdf (11.7 KB)

Forgot but I saved this at some point shows the settings and errors I was getting

1 Like

I had a simular issue last night. Jog funcions were greyed out and only the home button could be used. Clicking it did nothing. Restarting Gsender did not help. I had to pull power power from the long board reconnect. Home was still the only button availible. This time clicking home worked and after it finished homing all jog buttons were availible.

Processor Intel(R) Core™ i5 CPU M 520 @ 2.40GHz 2.40 GHz
Installed RAM 4.00 GB (3.86 GB usable)
System type 64-bit operating system, x64-based processor
Pen and touch Pen support

Edition Windows 10 Pro
Version 22H2
Installed on ‎2021-‎05-‎11
OS build 19045.3803
Experience Windows Feature Experience Pack 1000.19053.1000.0

RE: jogging buttons on UI - a fix for that should be out today.

Could you double check that you’re connecting using the grbl controller and not the grblHAL? Your report of 4 errors in the console would correspond to the 4 grblHAL specific commands we send on connection for hal specifically which leads me to believe you’re using the incorrect controller type. You can double check both the connection widget (grbl selected at bottom, all com ports labelled “use GRBL” and in the console (It should report the controller type at the top in the format “gSender - [Grbl]” on connection.


1 Like

I will reload 1.4 and let you know later thanks

KGN I reloaded1.4 connected GRBL on comm 3. Top left corner have brown padlock button showing machine locked pressing to unlock does nothing. The jog buttons do not work though they are shown in blue. Using the goto button and inputting a distance for X and Y machine operates. I can run a probe test. Loaded a short file and it runs fine. I have homing switches that I only activate when I want to lock in a co-ordinate. I was able to enable the switches in the firmware and the machine homes to front right corner as normal. The only thing I cannot do is jog the machine in X Y or Z. Attached are diagnostic file from yesterday and today.
diagnostics_1-26-2024_13-10-09.pdf (8.9 KB)
diagnostics_1-25-2024_12-51-24.pdf (11.7 KB)

I can confirm my issue was set up with Grbl selected

Yes, again, 1.4.1 is releasing later today and should fix the jog button issues some users are experiencing. Let us know if you’re still experiencing the same issues after that release.

It sounds like you’re experiencing something slightly different than the original post in that your UI is disabled completely. A diagnostic file (via Calibrate tool → bottom right) might help.


I will let you know when I download and try. Not a major issue as 1.2.2 works well for me.

1 Like

Kevin, 1.4.1 works well, thanks a lot.

@Parrott Has 1.4.1 resolved the issue for you as well?

New problem? The new “Go to” function only moves the set absolute location or relative distance in millimeters only, no matter which units are set (mm or in). V1.4.1.

1 Like

I initially had the failed Jog Control (via the screen icons but short cuts worked) in V1.4.0 so I quickly installed V1.4.1. Next problem … I could not load existing gcode files into the visualizer, but I was able to load from the generated Surfacing Tool path. Restarting gSender did not help. Rebooting my Windows PC did. It is working now but …

Thanks, we’ll get this fixes for next release.

Once updated to 1.4.1 the jog tools opened up after homing the machine. Should the jog functions open pre hominig? Feel like they should/were always usable to clear any work you may have placed on the bed. Correct me if I am wrong.

@Parrott I must leave this to others to answer. I don’t have switches on my LM. Sorry that I can’t help.

Homing is an exclusive operation. It must be done first, because the machine doesn’t know where it is. :smiley:

PS. My Shapeoko 3XXL has built in homing switches on XYZ. Your machine may not.

Good to know. Before shutting down the machine it will be good practice to park it at home.

I had to get a new laptop and so downloaded 1.4.1 which was current version. Worked but the visualizer kept having error where it would blank out. Said update was available so I figured maybe it would correct the issue. Thus was a bad mistake. Went to jog to zero workpiece and it worked but needed to go to the precise mode. After clicking precise then the arrow to move it moved a inch and at about 4000 inches a minute. Switched around between nirmal rapid a precise and they all had the millimeter numbers but using them in inches. Luckily I did not do a rapid move first as it was going to go 20 inches at machines top speed! Also after this and getting part zeroed with the touch probe I started the job only for it to be off also. The offsets for the probe were not there and my project was ruined. Hopefully this can get resolved quickly. Otherwise I’ll have to go to an older version.