With Gsender when I try to run the surfacing option

I put my values in and when I try to load Create Gcode the box does not allow me to load it. Nothing happens when I try to click on it. When Gsender is downloaded do I have to load some kind of file? Not quite sure how to ask this question.

I’m not 100% sure what you’re asking here - but the steps to generate and run a surfacing job are as follows:

  1. Setup your surfacing job with specific dimensions/options as desired

  2. Click “Generate G-code” - this generates the surfacing code that will be run. You should see a preview to the right of the surfacing options

  1. Click “Run on Main Visualizer” - this loads the file as a job to be executed and you can use the workflow controls as expected to start the job.


If you’re experiencing something different, please let us know what version you’re running and a little more detail on what step you’re getting stuck on.

1 Like

I don’t know if my previous reply went through.
Opened Gsender-connect to machine-select surfacing-set dimensions-select lower left-select zigzag-select zigzag-generate gcode. Nothing happens. Run main visualizer. A red circle with a line running through it. Nothing happens. That is what I did.

Can you send an exact screenshot of your inputs so we can try to recreate what’s happening? Which version of gSender are you running?

Hopefully these screen shots reach you and help. I am new at this.

1 Like

version 1.2.2 of Gsender.

1 Like

Hi Dean,

So looking at your input, your cut depth value is extremely small to the point of unrealism - 0.00001" is not an obtainable goal for accuracy. For reference, our cut depth default value for the surfacing tool is 0.04" - just over 1mm.

I’d recommend changing the cut depth to more accurately reflect how much material you want to remove and you’ll likely have better results.

For what it’s worth, the accuracy of the average hobby machine is around 0.01mm at best which is 0.0004in - you’re trying to cut 40 times more accurate than that.

If you need further explanation of the inputs and what they mean, we’re happy to go over them. We also have a video with Andy explaining the surfacing tool (https://www.youtube.com/watch?v=jfInIEOB3kU)

Thank you Thank You! I set the cut depth to.08 and it worked! I will watch the video and learn more.

1 Like

When I try to run the surfacing option the Z axis starts to go down as well as the X axis moves so I stop it.
In the main visualizer there appears to look like a blue line on a diagonal. I try to set the Z axis to zero but that doesn’t seem to help.
![Screenshot (5)|690x388](upload://diXzgvzs5qITjhj6WZcnplFN5CZ.jp

Thank you.eg)

The diagonal line/movement is expected - the surfacing algorithm ramps into the first depth cut by design rather than plunging. Ramping is always easier on the tools.

@Dean As @kgn has resolved your issue, I am closing the topic. Don’t hesitate to open new topics as you have more questions.