X and y axis problems

My y axis controls have reversed. Up is down and down is up. X axis is fine… Both the x and y axis movements are very slow though. It doesn’t matter if you have it on rapid, precise or normal in gsender, It moves in the same increments (1/4 inch maybe less) and sounds week or underpowered. The last carve i did was fine. I go to the machine days later and now this problem… The z axis moves properly and sounds normal. I also had these same issues while in Easel pro.

In gSender, in the firmware section you can change the direction of an axis. It is setting 3 “Step Direction Invert”. I have an original LongMill and the X and Z axis are inverted but not the Y.

As far as not moving well you should check that nothing is too tight. You should be able to turn the lead screw by hand without too much effort. If the lead screw is hard to turn check that the anti-backlash nuts are not too tight. Also you can check the nut at the end of the lead screw. This nut only has to be tight enough to prevent the lead screw moving back and forth. Likewise the anti-backlash nuts only need to be tight enough to stop the carriage from moving back and forth on the lead screw.

Hope this helps, let us know how you make out.

Might you have overwritten your Grbl $$ settings when using Easel? It’s a common issue with users with all kinds of machines.
Can you post your settings here, so a longmill user can compare?


Yup, settings were all messed up in the firmware. I restored to default and everything is back to normal. thanks for the reply’s.

As the original issue has been addressed, I’m closing this topic. If anyone else has a similar concern, feel free to start a new topic, which will ensure that it is addressed promptly.