X axis keeps drifting left

I’m at wits end. I’ve been having an issue where my X keeps drifting left throughout the job. (MK2 48x30) I have checked everything twice. V-wheels are tight, set properly, and clean. Rails are clean. coupler is very tight. The cut is not aggressive at all (settings below). See below where I did a test after tightening up the X lead screw nut and set $1 to 255. This is a simple area clear test. Board is (I think) maple. It didn’t appear to drift anywhere while moving strictly along Y (the last pass is nice and straight on both right and left)

I stopped the job because I can see where the current stepdown was already left by at least 1/2 bit width Compare right vs. left side of the pocket. Only thing I am unsure of is backlash screw. One thing I noticed is that the threaded rod/motor turn VERY easily while machine is idle. To me, if backlash was too tight, it would have some friction. This is why I tried $1=255.

Sienci 1/4" Upcut bit
Stepover: .112
Stepdown: .07
Feed: 65 inch/min
Plunge: 33 inch/min
Speed: 12,000 (makita setting 2)

I’ve been trying to get a 2.5D carve done but cannot get past the roughing with this issue. Tired of wasting perfectly good chunks of wood :frowning: .

@slovdahl What CAD/CAM software are you using? If VCarve, can you post your .crv file?

CarveCo Maker. I ran the same file without any material (raised Z up as well). I put in a v bit and marked X/Y zero on the spoilboard, ran the job and it was still spot on. must be something mechanical. Going to:

  • remove the router
  • remove the backlash screw
  • replace V wheels on X gantry
  • clean everything up
  • check connections to motors
  • reassemble and try again.

If it still acts up, I’m thinking about swapping motors with one of the Y motors and see if on of the Y’s acts up. Might check my spare parts to see if I have a spare backlash nut. I might also get some type of dry lubricant for the lead screw. Very frustrating. It has been carving just fine until this project.

@slovdahl It sounds like you have a good plan to diagnose the problem, Scott. Please post how you make out.

Well, I may have it resolved but you never know. Here is what I did:

  • removed the X gantry (router, etc)
  • removed the X threaded rod
  • cleaned everything
  • replaced X axis V wheels
  • reassembled and tuned everything just like initial assembly
  • resurfaced the same test board I had
  • re-ran the same pocket/area clear job (result in pic below)

I honestly think it was the backlash block. Just to see how minor (finite) adjustments impacted tension, I put the rod back in with the backlash block on it. Did not attach X gantry yet. Made very finite adjustments to the backlash screw and held onto it with my fingers while jogging X (left/right). It is baffling how just the slightest movement of the screw increases/decreases the tension on the block. Honestly that frustrates me as you never know when you need to adjust it until you ruin some good material and waste time.

@slovdahl Thanks much for reporting back with your success, Scot. The adjustment of the anti-backlash nuts is a bit finicky for sure. Over time, you may want to swap them out for the new spring-loaded models, which are self adjusting.

I’ll close this topic as resolved.