X Axis Possibly Missing Steps - Not Working Well

I’m puzzled on this one. I engraved some cutting boards the other week for a friend and noticed the laser is not burning right, the images are distorted/wavy. I have checked the mechanical items:

Changed the backlash nut and adjusted properly
Ran carriage end to end, no binding
Checked the set screws, they are tight
No loose wires

I have a MK1 machine.

I’m at a loss on what could be causing it. Here are some examples:

This is the bottom of an image setup to burn with a cross hatch. This part looks great overall

This is towards the top of the image (about 3 inches later)

You can start to see the double line off in the X direction only. Towards the top the text is terrible

This is another example of an issue. This is a large logo (18 inches in diameter) and I split the logo in half to make it burn faster (less white space to cover). The two halves should have formed a point, but it overlapped, again it seems like only the X is off.

Here is another example, this number is probably 2 inches tall

It seems to wander around as it moves up.

I just tried to adjust the current value/settings to see if that can help. I turned it to 1 o’clock on the potentiometer (1 step higher than it was). After that adjustment, I tried the cross hatch again:

Might have made it worse.

I’m at a loss for what to do next. Any help would be appreciated.

Thanks in advance.

1 Like

I have some more data I collected. The X axis is drifting over time based on what I’m seeing and it seems to always be drifting left (at least in the two rounds of testing I’ve done.

Here is the test setup:
Dial indicator setup to measure the router mount (English indicator)
I manually jog until the indicator is at 0
I run a GCode File (attached) to move 25 mm off the indicator and then 25mm back on, pause to take a starting position (in case there is backlash)
Move 450 mm off and back on a bunch of times
Pause to see how it drifted
See how it drifted.

Here are results:

Manual Jog

25 mm move off/on

Basically the same

First round of 450mm moves


It is now off .020 (.5 mm)

Second round of 450 mm moves


Same offset, which really puzzles me. I’d expected the drift to grow, not shift and remain the same.

I’m at a loss now on what to check next (this is after I slightly upped the current. Any suggestions/thoughts?

Attached is the G-Code file for reference. I have a timelapse video but it is too large, I’ll work to get it loaded elsewhere with a link.

Calibration Test.gcode (1.8 KB)

When you do the moves with the dial indicator, are they in the same direction or first one one way then the next one back?
If it’s a backlash type problem, the first move will show an error as the backlash is taken up but the next move, in the same direction ,will be fine as there is no longer backlash.

Lappa - The same direction

Turns out this was mechanical after all (feel a bit embarrassed honestly). Once I found a way to lock the motors (I forget the command, but set the holding time on forever) I was able to see the collar slipping on the motor. Without the motors held on, they just turned with the screw.

Live and learn, thanks for the help

@JayDent Thanks much for posting how you solved, this, Jay. I’m closing the topic.