X Axis sticking when using console commands

Hi All

I am trying to calibrate my 30X30 machine using gSender 1.2.2 and the calibration routine and I have run into an issue. When I insert the distance I want the X axis to move in the calibratiion routine (600 mm) the X axis moves about an inch then stops and makes a loud high pitched wine. If I just use the jogging controls the X axis moves fine. I’m stumped. I have loosened the V-wheels and the backlash nut to eliminate those but it still crashes after a short amount of movement. If I just put in something like X+50 in the console it moves a short way then stops and whines as well.


I’ve done a little more troubleshooting this morning.

When moving the X axis back and forth the motor makes loud humming noise.

I unplugged both Y axis motors from the Longboard and plugged the X axis motor into the Y1 port. When I use the jogging controls (Y+ and Y-) the X axis moves both directions and is MUCH quieter. Also using the console the X axis also moves correctly and quietly ( using Y+ and Y- of course) without stalling.

Bad Longboard? I hope not. The machine isn’t that old and I don’t use it that much like a lot of you guys do.


@StuartG Has it ever worked properly?

Yes. I’ve been using the machine for a while now. But the X axis has always made a weird groaning noise. I always thought it was just the V wheels maybe not being exactly parallel to the X rail. But since I tried using the Y1 port I’m wondering if the X port has always been the issue and now it’s beginning to fail.

I have been using the machine but I discovered that it wasn’t cutting square. So I modified my table to allow the right side Y rail to move back and forth to make adjustments. After running the squaring routine in gSender (which I just discovered) once and making the suggested changes I went to run it a second time to check my progress and that’s when the X axis started stalling. I only moved the right Y rail forward by about 3.3 mm so that shouldn’t affect the XZ gantry movement.

@StuartG FWIW, I would start by checking the driver dip switches, since, if I understand you correctly, it has never been good. It’s just worse now. Also, I would suggest that if you are out of square by 3.3 mm, you will not be happy with any intricate carvings you do.

If the dipswitches are fine, open a support ticket with Sienci. They will take care of you.

I’ll check them when I get home tonight. Fortunately I haven’t been doing any intricate work yet. Just some simple things. I cut out a few grooves in my spoil board to insert some fences and that’s when I discovered I was out of square. Still learning. I never ran the squaring routine when I first set up the machine because I didn’t know it was there and didn’t know any better.

@StuartG In addition to the squaring module, use the calibration module, too.

Once I get it working again I’ll do that. Thanks.

OK. I have some more data. I was able to get the machine working again by resetting the machine to factory then selecting the invert for Z at $2 and $3.

I then re ran the squaring routine, which I believe is also the calibration module as well as it asks for actual measurements of my machine movements. After I ran the routine I got the message that my machine was pretty square but that I could move the Y axis something like 0.68 mm and that the machine EEPROM settings will be updated to the following: $100 X steps/mm will be updated to 268 and $101 Y steps will be updated to 151.

After updating the $100 and $101 the machine begins stalling in the X direction again but not Y. I then opened the firmware settings and checked the $100 and $101 and they were set at 200.00 steps/mm each. So I’m not sure that the settings were actually changed or maybe only in some locations but not others.

I’m going to try manually setting these 2 settings to 268 and 101 and see what happens. I’m just not sure why one is over 260 and the other is only 100 when the default is 200 for each. During squaring and calibration I moved the X axis 600 mm and measured about 596 and the Y I moved 800 and measured about 797 and the diagonal should have been 1000 but it was about 997. I’m going to reset it and rerun the measurements again. Maybe I put in the wrong value, but the software did say I was really close to square.

Keep you updated.


This morning’s update.

I think the squaring routine has some bugs in it. It wanted to change my stepps/mm from the default of 200 to $100 - 268 and $101 - 150. All for about a 3 mm error in 600/800 mm in X and Y. Also when you allow the routine to change those settings it doesn’t appear to change them in the firmware as after you apply the changes and go into the firmware the $100 and $101 show 200.000. But it is changing something as that’s when the X motor begins to stall. After setting everything back to factory the machine runs normally.

So I calculated an approximate value based on how much I wanted the axes to move and how much they actually moved and I came up with 200.837 for X ($100) and 200.627 for Y ($101). After a few tests I had to adjust the X to 200.780 but the Y was spot on at my initial calculation.

Then I went back to squaring the machine using the gSender routine. After filling in the values that I got (X600, Y800 and Diagonal 1001.5) the routine once again wanted to change the stepper values to 268 and 150. I didn’t do that but I did move the right Y rail back the recommended 2.5 mm. That made the diagonal distance worse, so I disregarded the routine, moved the right y rail foreward 5 mm and the diagonal distance was 1000.5 mm. I then moved the right rail just a hair more foreward and now my triangle distances are 600, 800 and 1000 mm or as close as my eyes can read the rule.

So the machine is now theoretically in square and the axes are moving the correct distances. I have to make a new spoilboard and then I can cut a few squares on some scrap and see how square the corners really are.

Once again, for those who are following I’ll keep you updated.


1 Like

It’ll be interesting to see how things work out for this problem you’re having. I have a suspicion that by having incorrect driver dip switch settings, you’d created the problem(s) yourself. But it appears that your gSender may be suspect, too. What I’d consider doing is reloading gSender’s most recent version and see if that helps you out.

Marty from Kingston, ON, Canada

Sorry for the delay in responding. Just got home from work a few days ago and am now getting back to this.

I have checked the 4 dip switch blocks under the Longboard and all are set per the assembly instructions.

I was able to get the machine very close to square just using a ruler and tape and marking the points and measuring in all directions. I was not able to use the gSender stepper settings recommendedby the software. As previously noted it wanted to change the stepper values from 200 each to 268 and 150. I think those were causing the machine crashes. To get the X and Y movement distances correct I changed them from 200 to 200.780 and 200.627. A massive difference from the software recommended values.

I cut a few squares on the machine and the corners on the right side are spot on at 90, and the left side are very close but not perfect. That might be caused by a slightly out of tram machine. I’m going to work with these settings for a while and see how things progress. I’ve got a feeling that things are going to be pretty good.