X Carve Questions

Hi team!

I’m new to CNC in general, but very new to gSender. I’m using an older (2020) X Carve 750x750 with Vectric Vcarve for my CAD/CAM software.

No problems so far with saving gcode and running on gSender - it seems to really work great, and I love the visualizer!

That said, a couple of newbie questions:

  • Where do I find the often mentioned machine profiles/pre-sets and where do install those?
  • Can I follow the same instructions in the documentation for gSender to enable homing switches, or are those instructions specific to the Longmill CNC?


Welcome to the group Tim!

I think the machine profiles are just in the firmware settings for flashing firmware. If your machine was working well with another sender you shouldn’t need to flash though.

The gSender documentation isn’t LongMill specific. You can enable homing, hard and soft limits in gSender’s firmware tool. That said if you had that stuff set up in your last sender it should still be set up as those settings are saved on your control board.

If you do need to set up switches then there are two scenarios. Either you have one switch per axis or two per axis, one on each end. I’m not sure how the XCarve is set up in regards to the number of switches. Anyway if you have two switches per axis you need to have homing and hard limits enabled. If, on the other hand, you only have one switch per axis then you need to enable homing, hard and soft limits. You also need to set the machine dimensions in the firmware for soft limits to work.

Relevant firmware settings are:
20 - Soft limits enable
21 - Hard limits enable
22 - Homing cycle enable
23 - Homing direction invert (use this if an axis homes the wrong way)
130 - X-axis maximum travel
131 - Y-axis maximum travel
132 - Z-axis maximum travel

Hope this is helpful and welcome again.

Ok awesome - I’ll work on the homing limits.

I guess I was just assuming that since in the calibration tool tells me that I have the longmill 30x30 profile loaded that the dimensions (at the very least) were off.

I’m not experienced sending gcode to GRBL devices - is there a guide for the syntax on those gcodes?

Also - once I send the soft limit enable gcode, I assume I can manually trigger my homing switches and they should toggle on in the calibration console? I’d love to make sure they are working before I try to home the machine.

This was a used machine that apparently sat around not being used for the last two year - I have no idea what state the firmware is in.

Thanks so much for the detailed response!

All of the settings that I mentioned can be set with the gSenders firmware tool. Next to the calibrate button is the Firmware button and you can set the profile in there and check the firmware settings.

You can see in the screenshot the profile selection at the top, once you open the Firmware Tool. In the main area you can scroll through the settings and check/change the ones that I mentioned. The user interface makes it easy to change the firmware settings, just don’t change things that you don’t understand yet. You can also Export the setting to a file which is a good idea that way you can get back if you mess up.

Wow! They have added that since the last time I checked in Calibrate. They are always making gSender better. I just tested on my machine and yes, on the Diagnostics Tab the “light” will light up and change to On when a switch is triggered. That is hard limits though not soft.

The switches are the hard limits and the soft limit is a software limit for when you only have one switch per axis. The way the soft limit works is after you home the machine knows where “Start” is and it can add the number that is set for maximum travel to tell where to stop before hitting the end without a switch if that makes sense.

So if you have one switch per axis enable hard and soft limits but if you have two switches per axis you can leave soft limits off.

Oh and that screenshot is from my test Arduino that isn’t hooked up to a machine so that’s why homing and limits are off in the screenshot. They are enabled on my machine though.

Awesome info - thank you so much!

I’m going to play around with this more later today and I’ll let you know!

I really need to enable homing since I have the switches, so this should be fun.

Thanks again!

1 Like

Good luck, I’ll check back later to see how you made out and you are most welcome for any help I have given.

1 Like

So I was able to apply the xcarve profile and theoretically turn on the limit/homing switches. Unfortunately, either they aren’t working or the firmware/gcode send didn’t work. I have read that the xcarve switches break really easily, so I’m going to order some omron ones off the amazon and see if those work.

I do need to dive into the calibration functions though - I noticed yesterday that when I did a finishing pass cutting a square block of wood the pass worked well on the Y axis, but missed on the X

Thanks again for your detailed response!

1 Like

So all of this led to a little adventure…

I was changing these settings in the firmware tab, and I accidentally hit flash GRBL instead of apply changes.

So that screwed up my movement in all three directions (tiny moves only) and also reversed the direction in all three axes.

I was able to go into easel and get everything back.

That said, one interesting thing is that my x and y homing limit switches show up in the easel machine tuning area, but they do NOT show as triggered in the gsender calibration tool when I push them. Not sure what that means.

I’d love to be able to home the machine, but so far no luck.


I have a fully updated X-Carve 1000x1000 and chose the X-Carve profile that came with gsender 1.2.2. I concur that the limit switches do not show as ON in the diagnostic tool. By updated, I mean it is an older X-Carve that has been brought up to date with all the options that Inventables has to offer.