X Y Z Travel seems off

My X axis does not seem to travel the width of the machine, I have a 30x30 MKII and when I travel with X roughly a half inch away from full stop I only get 22.226 width. My Y travel is 33.480 which seems normal?
Z is also roughly a 1/2 inch from stop.

Can somebody chime in and tell me what is going on, I surfaced my spoil board last night which turned out amazing. I would like to carve grid lines in it but until I can get confirmation that everything is good I will not proceed.

1 Like

By any chance, did you run the “calibrate” program in gsender?

Yes I did before I performed the spoil board surfacing.

Not sure I understand your problem. Are you saying that the machine travels the whole way from left to right and only reads ~22" or that it only moves ~22"?

Do you have the inductive sensors? If you do you should have homing enabled as well as hard and soft limits. The soft limits require the machine dimensions to be set correctly in the firmware $130 - $132. Just throwing that out there just in case even though you didn’t mention any alarms or errors. That’s another question, are there any errors or alarms?

EDIT: You said you did the calibration test, did you have to change any of the steps per mm? They are firmware settings $100 - $102 and they all default to 200 and if they are changed I would expect them to still be pretty close to 200.

1 Like

Yes, the machine travel shows roughly 22" as shown in the attachment. I did have to change the steps during the calibration test, I thought this was necessary since it was shown in the calibration process.

Where can I find these Firmware settings you mention, I want to look at them and can they be changed?


@_Michael, @ozguzzi ,

Quick update, the Firmware settting 100 was @ 297 which explains the X travel. The Y setting 101 was @ 197. I reset them both back to the default value 200 step/mm and everything is working as far as travel goes. Now I need to create my grid lines on the spoil board.

Thank you gents for your responses and input.


1 Like

From your post after the one with this quote I take it you found the firmware settings in gSender. You can also view them in the console by entering $$ and change them by typing $[setting number]=[value], brackets used to indicate a paceholder and not in command, but the settings in gSender are easier to get started with. If you ever need to check default values you can find them in the LongMill MK2 resources here. The ones that say [mask] are a bit mask, a combination of values, and require a table to find out what values do what. Those tables as well as info about what each setting does can be found here on the GRBL Wiki.

If you measured correctly and gSender told you to let it change the values and it set it to the numbers you gave then I’m wondering if it’s a bug, you’d have to measure pretty poorly to be of by ~50%.

As the OP has resolved his issue, I am closing this thread. Thank you, guys, for pointing @GettingStarted in the right direction.