XYZ Probe with AZTP setting wrong Z zero

I am using gSender with a Shapeoko Pro. I am using an AutoZero Touch Plate. I have selected the AutoZero Touch Plate in the settings section and gSender does what you’d expect for an XYZ probe cycle when using the AZTP.

My problem is after the probing, if I send my bit to the zero point, the bit is 1-2mm above the workpiece. The X and Y zeros appear to have been set correctly.

Any ideas what to do to fix this issue?

How are you placing the AZTP device on your part?

Are you actually using the XYZ choice on the probe menu?

I am selecting XYZ from the probing menu. I am placing it on the workpiece in the manner pictured.

What does your gSender display show on screen for Z-zero?

I’m assuming “0”, but have to ask for troubleshooting.

That is correct. After running the probe cycle the bit moves to the lower front corner and runs itself to a Z height of 1mm. I then send it to the Z zero and it moves down but is still 1-2mm above the stock.

Are you sure you are pressing the left edge of the Zero button? It sounds like you are pressing the right side and changing your Z-zero to where ever the machine stopped.

The button has two functions.

I understand. If I click the zero button the position changes to 0 without moving. If I click the “GO TO” button the position changes to 0 with the bit moving 1mm down. It is still 1-2mm above the workpiece after this move.

Well, I don’t know. Mine works fine on XY zero, but I haven’t even used the XYZ function.

All my projects are designed with the Z being referenced to the spoilboard rather than the surface of the material, so my Z-zero is done off the material.

I’ll have to do a setup on my machine before I can see if mine is working like yours.

I appreciate the attempt. It seems like an obvious bug but I don’t know where to go from here without doing an extra step to redo the Z zero each time.

I’m just busy with life right this moment, but will investigate more this evening. I want to know, too.

@SuperDodge I don’t have the auto touch plate, but in the interest of trying to figure this out, I have a question. What kind of end mill are you using and do you have the probe set to auto or tip?

Using an 1/8" end mill with the probe set to auto.

@SuperDodge I knew that it wouldn’t be that easy. :grinning:

I would advise to open a support ticket with Sienci.

@SuperDodge I did get a chance to test the XYZ probe on my Shapeoko 3XXL and did not have any problem setting XYZ zero with the AutoZero probe using a ¼" Dia. gage pin.

I remembered that I did have a problem with a tapered ball nose bit when I first got the probe block, but that went away after the first trial. The process “skipped” the last move to the XY zero location before it drove the bit into the bottom of my block creating a permanent indentation. It only did that once, though.

So weird that you don’t get the same results.

I’m sure I should be smart enough to find this on my own, but I can’t. How do I open a support ticket?

@SuperDodge I would have thought that between you, me and Tex, we would figure this out. Wrong! :grinning:

To open a support ticket, to here and complete the form

What version of gSender are you running?

Or of curiosity, shot in the dark, what’s your $13 value?

Don’t know about @SuperDodge yet, but my $13 = 0.

1 Like

I’m wondering if his is set to $13=1. I remember this causing issues in cncjs, but I’m pretty sure this was resolved with gSender early on.