XYZ zeroing problem

I have the zeroing plate, but I’m having a small issue that I’m hoping someone can address.

I put the plate in place on the work piece and click to find x, y and z. The longmill finds z first, then moves to x and y. It then moves back to where I placed it to start the process. All seems good. However, when I start the cut, it’s clear that the z was not saved. The longmill runs the program, keeping the bit above the material. I can stop it, go back and set only the z and all works fine.

Is there some sequence that I should be following to prevent this? I’ve watched Chris’ video and I believe that I am following it, but clearly, I am doing something wrong.

Thanks from a CNC newbie.

I’ve not tried this, but try hitting the return to zero button in UGS - this will set the machine back to the actual zero point calculated by the machine. The bit should be right at the outside corner.

Also, triple check your Z-thickness in the probe plugin - It could be off, there are a couple tabs of info to set up. If you are using XYZ you need to set the attributes in that menu, then you need to go to the setting menu to set the speeds if I remember right.

Thanks much, Mike. I’ll give that a try.

When I hit return to zero, the machine does return to the zero that I have set, but when the code runs, the Z axis is clearly off, as the bit never touches the material. (Better than too deep, I suppose. :slight_smile: )

You are zeroing it to the round circle on the plate right not on the edge? Or if you are using the plate in the middle of your work you have to turn it over or it will not work right? The edge is thicker so it throws off the calibration of the machine.

ok, I am wondering about your design then, make sure the origin in your GCode matched the zero you are setting. For example, if you have the zero in the g-code set to the bottom of your workpiece, and the machine set to the top, you will be off by the thickness of the material.

in UGS you can see the origin, when you see the displayed g-code, you can pan that image arounnd and see. But I bet you its the original do not match.

What program are you using to generate the g-code?


oh I guess the other thing to check is that the machine moves correctly as well - when you hit z+ in the job, the z axis moves up right? and z- moves down?

Also with regard to the g-code, the axis set in your program could be upside down :slight_smile:


I’m using Vcarve Pro. I set the z0 to the top of the material.

Just to be clear, Mike, I do get UGS to work. I just need to set the z twice.

Yes, it moves like it is supposed to.

Ok - you are not hitting reset zero after using the probe, are you?

I’m going to go to the shop now and try again, ensuring that I account for everything you’ve mentioned. I’ll let you know how it works out.

Cool let us know - I accidentally used the probe to zero, and instead of hitting return to zero I hit reset zero, which just set the zero to the point right above the touch plate.

I also left the touch plate on the workpiece the first time, and hi return to zero and put a little divot in my touch plate. I did mention to Chris and he updated the documentation - since it was literally the first time I used it I wasn’t thinking it through.

You’ll get it sorted. Will be cutting projects in no time!

1 Like

I had the same issue. It took me a while to figure it out. My touch plate has the scars to prove it. Here’s what I do now:

  1. Mount the touch plate on your material.
  2. Attach the magnet to the collet nut. DO NOT FORGET! This is where the scars happen.
  3. Position the bit over the circle and drop the bit to about 1/4" above the plate.
  4. Press “Reset To Zero”. This sets X, Y and Z to zero.
  5. Run XYZ probe.
  6. When finished remove the touch plate and magnet.
  7. Press “Return To Zero”. DO NOT HIT “Reset To Zero”. Bit should move down to the corner
    of your material.
  8. Reset your dust shoe to top of material.
  9. Power up vacuum and router.
  10. Load gcode and press run.
  11. Happy cutting!

Thanks much to both of you.

I played with it some more yesterday and did get it to work. I’m not sure that the problem was with the Z axis, and I did not report here on the issue with X and Y, but I did find that the problem there was that the settings that I had put in, as instructed by Chris, had been lost somehow. That meant that the bit was not really touching the plate in X or Y. I re-input the settings and all was well.

I’ll be in the shop shortly and will check to see if the settings remained this time.

I am also learning that doing the set up with a V-bit is a little hit and miss.

Glad to see you figured it out. I also had this happen to me at first. It’s saved the settings every time since. Not sure what happened. Though I suspect I updated UGS or something and overwrote the config.

For the v bit I’m not sure there is a good procedure for the touch plate honestly. What I tend to do for my v carve stuff is one of two things.

Easiest is set the origin to the center of the workpiece and then draw the center x on the work price. It’s pretty easy to jog the machine to the right spot. Either use the prove to set zero, a piece of paper, or simply loosen the collet and sink the z axis down towards the workpiece. Once the tip of the bit is touching and enough of the shank is in the collet tighten the collet and hit the button to reset only the z axis. If I swap out the v cutter to an end mill I will jog the machine over to a flat area. Remove the v bit and follow the same process to reset only the z so the x and y zero is the same.

The other thing I have done is design and cut a jig. I had a little box lid, I designed a jig with a hole pattern to match my spoil board so I could bolt it square, then carved out a holder for the workpiece. I set zero to the lower left corner. When I design a new box lid carve I import the jig file and draw my design on that and export it. My zero is the lower left of the jig. So I can zero to the jig and place in a new box lid

Just a couple ideas, glad you got your zero problem sorted!

I think the ‘standard’ approach for using a calibration block is to set X and Y with a straight bit, replace the straight bit with the v-bit, and set Z.

1 Like

Mike: All good ideas. Tks much

Bill: I had read that. I just don’t have a 1/4" shank straight bit, with a diameter of 1/2", which is the diameter of my V bit. I have a micro metal lathe and I’m going to make a piece that will allow me to do what you have recommended.

Happy New Year, guys.

It doesn’t matter what size straight bit you use. It could be a 1/16 inch bit. It will always place the center of the bit over the corner in the correct spot. So, if you switch to any other size bit it’s center is over the corner. Hope that makes sense.

1 Like

The X and Y zeros are based off of the center of the side of whatever size straight bit you use. The Z will be based off the bottom of whatever bit you use. They do not have the be the same, in fact, if you’re using a V-bit the X and Y zeros will be affected by the height where they touch the calibration block. That’s why you use a straight bit - same diameter all the way up.

I believe that I understand you both. However, I assume that the diameter of the bit that I use to determine x and y must be the diameter that I specify in the diameter field of the probe window, correct?

So, I could simply enter .25" in that field and always use a 1/4" bit to set the x and y. Then insert the bit that I will use for the job, set z and all will be well.

1 Like

Hello Sirs,
got the same issue, but noticed a line “G28 G91 Z0” in my Gcode, which is a “move to origin (home)” command.
Using inventor to generate my gcode, I can turn off the “G28 safe retracts”-option in the preferences, which works fine.
Cheers Jannik