Y-axis Stepper stalling while zeroing on touchplate

#1

Having some issues with the Y-axis stalling (and doing other weird things) while zeroing on the touch plate.
If I set up the pad and start the macro, the machine will do the Z & X just fine, when it rapid advances along the Y axis you can hear the stepper trying to stall about half way through the motion. It will also make that sound while it is cutting occasionally, but it dos not seem to lose it’s position.
It DOESN’T make the stalling sound while jogging.

On the same note, it seems that I have to restart the UGS software to get it to go back to zero reliably. If I click the so back to zero button first time it is fine, after that it will zero about 6" to the left of the measured zero. and sometimes when it does zero (or appear to) correctly - it cuts (a small vcarve test) it will cut that about 6" to the left of its actual position.
And once in a while (3 times) while trying to zero, it advanced all the way up to the extreme back/right of the machine!

I did have an issue where the Y axis appeared to be stalling, but that was me having the jog feed rate set too high for the machine 5000, I assumed that if the machine could not move that fast it simply would not do it… wrong. - I’m hoping this is a case of me not knowing the software well enough.

  • using UGSPlatform for sending/zeroing
  • pattern was made in Illustrator, exported as SVG and then into Carbide Create (not super thrilled with the software)
  • I had checked ALL the nuts on the machine
  • checked the anti backlash nuts and eccentric nuts
  • nothing that was not supposed to move moved lead screws could be turned by hand freely
  • delrin wheels also could be moved by hand but not easily…

Dunno - kinda frustrated at the moment.

#2

I asked a similar question of @chrismakesstuff a while ago about “what if you send the machine to a position it doesn’t support (e.g. past the end of the axis reach)” and his answer (as only an engineer can say) was “if you tell the machine to go there, it will try and go there”. I took that to mean there aren’t any guard rails or adaptations for things like over-proivisioning jog speed, so something to bear in mind for all of us I guess.

Given that the CAD and CAM software and the gcode sender are all independent components from (most) CNC machine, it does make sense that the machine vendor can’t easily implement “sanity checks” and instead need to rely on operator knowledge. Also, as people modify and enhance their machines (in size or motor power etc) it may be necessary or desirable for them to do things outside of the “guard rails” so, on the upside, it keeps things “extensible”. :slight_smile:

-Jeff

PS - Sorry I couldn’t offer any assistance with your main issue, I don’t have my machine yet. Hopefully someone will be along shortly who can offer some ideas of what to try next or to help diagnose the motor.

#3

Some people have been having issues of certain axes on their LongMill struggling or losing steps during operation and the culprit was that they had over-tightened their v-wheels. The wheels should be tight but you should still be able to turn the wheels with your fingers. Another common issue has been that the motor connectors on both sides haven’t been fully pushed in. The y-axis of the machine is set to be limited to 4000mm/min by default and will not stall at this speed; it also shouldn’t be able to exceed this speed unless you changed your LongMill to do so.

Your issue with the probe zeroing does sound odd to me, as long as the probing cycle ends by returning to the original spot you started it, then it should confirm that the zero has been set. This should also be confirmed by the digital readout (DRO) in UGS. Give me a call if you’re need assistance with this: https://sienci.com/contact-us/

#4

Yes, that does make sense - the controller itself really has no idea what position the gantries are in when it is turned on - so yes - makes perfect sense. desirable behavior actually - I think I may have read that comment (if it was on facebook), my understanding was that “Yes” the gantries would hit the ends of travel and stall out the stepper servos, but not actually damage them. I dunno - maybe it won’t damage the motors, but I can’t see slamming into the rails/gantry etc being good for any part of the machine.

No machine yet??

  • buy some 16/18awg wire for the Z axis connector - it is way too short, leavse you about 4" of slack to position the controller
  • I have had some issues with the aluminum socket heads galling with the aluminum - I actually got a spark and puff of smoke from the router mount! - treat the bolts that are threaded right into the aluminum parts.
  • several of the smaller socket heads are stripping - I stripped one for sure, and a couple came assembled & stripped … I’m going to replace all the small ones (socket heads) with torx drive types.
1 Like
#5

I had done all the troubleshooting - the wheels appear to be have the correct tension, I did actually have an issue with one of the control cables coming loose - but that was easily found (no movement as opposed to a stop - start grinding)

as for the speed - well, you can set it as fast as you want in the software USGPlatform and the controller will try to go that fast, but it will make a stop/start stalling sound… (and not move) same sound it makes when you do try to run it past the working area (and it runs into the rails)

I was beginning to wonder if there was a firmware setting that was out - this controller is actually a replacement, the first controller had one of the Y axis not working at all. Is there a firmware flash utility? I noticed in the UGSPlatform software there looked to be a “settings” for that sort of thing - but did not look closely.

Right now I am 90% sure it is not a mechanical issue, thinking:

  1. EMI issue
  2. Firmware issue
  3. User issue :wink:

I’ll post a video of this thing trying to zero out on the touch pad later on (on facebook) If I keep having issues - thanks I probably will take you up on the phone call offer.

#6

Yup - my machine is officially down - I completely disconnected the Z axis gantry from the X axis lead screw and ran the zeroing again. same result - it stalls and the lead screw does not even try to turn but does make a horrible sound. Videos posted in the group on facebook. when is the “give me a call” offer valid? business hours??

#7

Validate if this “noise” is what you heard from the original symptom:

https://youtu.be/39Yqbb7jIpc

This could be the original symptom you originally encountered.

#8

yes exactly both noises … my machine won’t zero at all now … even if I manually set the XY and probe the Z … returning to zero sends it off into orbit …

#9

Yeah anytime that we’re in the office during working hours, Andy or I can give a hand

1 Like
#10

Thanks going to run through all the mechanical stuff and review the software setup one more time - so probably not until tomorrow or Friday.