Z axis movement in Gsender

Hello! Suffering through my learning curve again. When I use the Z+ button on Gsender, my router goes down. When I use the Z- button, it goes up. Something happened as I don’t believe it was that way originally. I noticed it when trying to use the touch probe. When it starts it goes up and errors out. Solution? Thank you!
Jake

@Jake Is this the other question?

I feel like this has happened to others and the answer is here somewhere in the forum - fairly recently. Something with changing a setting (reverse) in the gSender settings. Not sure if this is a fix in the current 1.06 version, or something suggested by Sienci - @KGN ?

Perhaps someone else can confirm or deny this as I am currently not running gSender or a LM :cry: … and I could be totally wrong about this.

1 Like

Thanks @stevendq I will have a look and see if there is a fix in gsender

I noticed it specifically when using the touch plate. Goes the wrong direction when I attempt to zero…

If it works correctly in normal jogging other than the probe, it could be a glitch in the gSender version you are using. I did tag Kevin on the Sienci Development team in my last post.

Other than that I am unfortunately of no help. Perhaps someone else has this issue and has solved it.

I really am unsure Steve. It seems to me it is opposite of what it was in an earlier version of gsender.

1 Like

Hey,

This isn’t a gSender issue - it’s either related to your EEPROM settings or a faulty connection - especially if it happens both when you jog and try to probe. Nothing has changed with either of those functionalities in any recent build that would cause both to move your router in the wrong direction for only one axis.

Connect to your board in gSender and open the firmware tool - The value of $3 should be one of two settings based on which machine you own:

MK1 Longmill: $3=5 (So X and Z toggled “on”, Y toggled “off”)

MK2 Longmill: $3=1 (X toggled “on”, others toggled off)

So the first thing to check and correct would be that. You can type the appropriate command in the console ($3=5 for MK1, $3=1 for MK2) or use the firmware tool to change it

Past that it’s 95% an issue with the physical connection - make sure everything is still seated correctly in the board and that the wiring looks correct based on documentation. Hardware issues are a little outside of my wheelhouse, so if the above two steps don’t work for you I’d contact support.

Kevin

2 Likes

@KGN Thanks Kevin. That was EXACTLY the problem. Adjusted the Step direction in the $3 area and my up and down is now corrected. I greatly appreciate you taking the time to assist me.
Jake

2 Likes

@Jake Glad to see that you are progressing, Jake.

As the original issue has been addressed, I’m closing this topic. If anyone else has a similar concern, feel free to start a new topic, which will ensure that it is addressed promptly.