Z Axis not zeroing correctly

Hi All,
I’m hoping someone has had this issue before. When I run a job, I first zero xyz using a probe, then when the job runs the z goes higher than what was zeroed resulting in the piece not being cutout deep enough. This happens using UGS or gSender.

It’s probably just some simple thing I’m missing…any one have any ideas on what to do?


I have a couple questions.

First is the Z zeroed to the correct height before running the job? Check by jogging off the corner of the stock and use go to Z zero to check.

If it’s not correct before the job then it’s a probing problem. If it’s right before starting the job but it cuts to high then it’s a problem with the G-Code.

What software did you create the G-Code with?

What type of machine do you have?

Hi @dbraz77,

Pasting from another thread:

First - check and see that the Z zero position in your model is the same as the Z you are dialing in with the probe.

After that, typically after that there are a few potential sources of Z axis irregularities:

  • check that the coupler between the Z motor and lead screw is tight
  • check that the bit is tight in the collet (always tighten with the two supplied wrenches, never with the red bit lock button)
  • check that the router is tight in its mount
  • ensure that you are not plunging into the work so quickly that the Z motor is losing steps

From my experience, an up-cut bit might pull itself into the work and a down cut bit might work in the opposite direction.

Edit: @_Michael and I are fully on the same page :wink:

Z height is correct before running the job. I run the job and the bit does not plunge to the correct depth. After the run has completed, I return to xyz zero and the z is about 1/4" higher now than what it should be.

I used Carbide Create to create the gcode and I have the 30x30 longmill.

The simulation looks good in CC but I guess it’s a problem with the gcode file?

How can I trouble shoot this issue? I attached the gcode file in case it helps.

ros_brake_pad.nc (18.2 KB)


I figured it out…I’m using 1/8" bit which is pretty short and the router was hitting the limit of the z axis. I just mounted the bit further out and problem solved.