Z Axis plunges deep into material even after zeroing

Longmill MK 1 30x30
GSender 1.1.7
Vcarve Pro 11.503

Here’s the issue.

I set the X,Y and Z using the standard touch plate. I then command to return to X,Y zero and the machine moves to the proper place. I then command to return to Z zero and the bit moves down and touches the workpiece. I’ll then move the Z up manually using GSender to a safe height and then turn on the router and hit start. The machine then moves to the start point and plunges deeply into the workpiece ruining it. I’ll then stop the job, raise the bit and turn off the router. I then reset Z again, test the Z height again and then restart the job from the beginning and everything is fine. It seems to happen on the first job of the day and doesn’t seem to occur again until a later day.

I’m at a loss. I have read in a few threads about grounding the machine and am working on a plan to do this. I assume I’ll have to ground each of the 3 rails and the Z gantry but am trying to figure this out. I might be able to run some wires through the drag chains.

Edit. It has happened with 2 totally different types of jobs so I don’t think it’s a gcode issue.




I’ve been in your situation too and still don’t know

Stuart when you have zerod with touchplate and at xy zero position why send x to zero? I would set zero with touchplate send to xy zero then start job. Try and see, it may or may not help.


Sending the Z axis to zero after setting is a test. It did it again today. After setting the Z I hooked up the shop vac. I then tested the Z height and it plunged into the workpiece. Fortunately it was a 30 degree V bit and just put a small hole in it. I reset the Z again and proceeded without further issues. I’m leaning towards a grounding problem with the dust collection. I hadn’t had any problems like this until the last few weeks and it’s been very dry. Perfect conditions for static discharges.

I’ll perform further tests and update.


1 Like

@StuartG That has been my guess and the only thing I can think of besides me somehow doing it.

I have only been at this for a few weeks but I think you could look in the console before hitting start button and the gcode would show you where gsender thinks the bit is. You maybe correct and you are dealing with a static issue. But I still question why always at the same point in the job.
Hopefully others here can provide better input.

1 Like

Once you have the router randomly take off non-stop in any direction you lose trust in it.

This is true.
However, for me, it has been like training a dog; as we work together longer and longer, the runaways are happening less frequently. I may soon be at the point where I can semi-confidently replace my tattered wasteboard, hacked up clamps and disfigured clamp knobs.

In the short time I have been up and running I have found the machine not operating as expected has always been traced back to me not doing things correctly. I am like you Greg, an old dog trying to learn new tricks. It sure is an interesting journey.


Here is a little write-up on the static build-up. However, it doesn’t mention runaway movements on any axis. I do wonder if this is the cause.

Noise, EMI, & Grounding - LongMill CNC (sienci.com)

I’m searching my shop now for copper wire. I’m sure I bought some at one time for this purpose.

Relative humidity this morning was 5% and my Longmill / gSender is working just fine. No fancy copper wire grounding. Baby girl Rottweilers get a little zap when I give them kisses in the morning. Never run from a Rottie!
I digress


Static in dust collection systems has been around since dust collection was invented, the issue being fire created by static discharge. Using none grounded hose and non conductive pipe work such as pvc beiñg main culprits. If I thought that I was dealing with a static issue that is causing the machine to make unwanted movements I would be more inclined to replace the motor cables with sheilded cables and possibly look at ferrites.


@Mickus sounds like you are on the right track!

@StuartG have you tried without dust collection?
I have Z issues as well. I’ll try your Zeroing method next time to see if I can prevent mine from deciding itself where Z0 should be

I’ve tried both with and without dust collection but have not kept track of the failures as to dust collection setup.

Short. My last failure that destroyed a workpiece I had set the Z, tested the Z then hooked up the dust shoe and turned everything on and hit start. After I stopped the machine I took off the shoe, reset Z, put the shoe back on and re ran the job.

Mickus. Where would I get shielded cables and what are ferrites?

I’m hitting the road tomorrow for work and will be back in a week. I’ll keep you all posted.


Stuart you should be able to get 4 wire shielded cable at any electrical outlet. lowes. HD. and probably Amazon. You would need 18/4 cable. If you go that route you should only connect the shield at one end normally at the signal source and i.e at the control box not the individual motors. I would install a ground bar and wire all the shiels to that then run a wire from the ground bar to a good ground, emphasis on good ground.
Ferrites are I think, some sort of ceramic and iron compound that produces a magnetic field around the cable they are attached to and consequently disrupt emf in the cable. Again these would be located at the source end of the cable. These may be a bit more difficult to find but amazon would be a good place to start.
In my limited experience of investigating emf issues in control systems I have always found that lack of a good uninterrupted ground either within the machine or from machine to building ground has been the root issue. Quick checks with a OHM meter will highlight ground issues, there should be zero resistance in the grounding circuits.
I wish you well and hope you get the issue sorted. Gremlins as Swinly calls them can be difficult to find and especially so when dealing with intermittent problems.

I have the same issue, still scratching my head as it only does this with the v-carve bit, the end mills do fine? I’ve been using the CNC with Carbide create and motion for a couple years. So I do understand CNC. Im using a shapeoko 3 xl, vcarve creative software and g-sender . I also notice that when I choose the - bit, Vcarve alerts and says I will cut though the substrate. I have only set the z to cut 0.05" deep but it does jam down to spoil the piece. I’ve deleted the tool paths, recreated the design and it continues… Tom

1 Like
1 Like

@Rxman If you would like to post the .crv file, people here may be able to help you resolve your “diving” issue. :grinning:

1 Like