Z axis will not move up or down

The Z axis stopped working on my Longmill MK2. I tested the motor by plugging it into the Y axis port and the motor worked as it should. could someone help me fix this problem? Thank You

Have you checked if the anti-backlash is over-tightened? Or if the set screws on the couplers and nut have come loose?

@sven Since you know that the Z axis motor is good, I suggest that the problem is either a bad driver or a bad cable.
To test the driver, you can run the cable from the Z terminal on the long board to the X motor. If you jog in Z and the X axis moves, you will know that the Z driver is good.
You posted that you swapped the Z with the Y and it worked. What cable did you use? If you swapped the cable at the motor end - that is, you used the Y cable to drive the Z motor, you don’t know if the Z cable is good. To test it, use the Z cable to connect the X port with the Z motor. If it works, you know that cable is good. If it does not, the cable is bad. If that is the case, check the four screws in the connector to ensure they are all tight.

(I’m suggesting swapping with X instead of Y since you are only jogging one motor.)

1 Like