Z operating reversed

Similar to last topic. I was attempting to complete a surfaceing operation and the machine seemed to start fine, I have 48 30, then I noticed soon after starting a noise as though the router bit was struggling. The bit had ramped down to 4mm before I got it stopped. The z step down for surfacing was set at 0.05 mm. It happened after the macine had done the perimeter cut and 2 full side to side cuts then on the 3rd did a ramp down and ruined my spoilboard. During investigating what may have happend I noticed z zero had changed and the z was operating in reverse. I checked firmware and z was inverted as was x, laser mode was enabled, I flashed for a 48 30 and checked settings again, z was still inverted.
Question, is there a listing of what the firmware settings should be? I want to manually set all parameters before I replace my spoilboard.

Here are the default settings.

In the hopes that it’s useful I’ll mention the settings that I usually have to change/check.

  • $3 - Flip any axis that jogs backwards here.
  • $30 - $32 Set these if you have a spindle or laser.

If you have limit sensors, check $20 - $23 and $130-$132:

  • $20 - Enable soft limits if you only have sensors on one end of an axis.
  • $21 - Enable hard limits to enable the sensors.
  • $22 - Turn on homing.
  • $23 - Flip any axis that is homing backwards.

These don’t hurt to set correctly without soft limit, and are necessary with soft limits.

  • $130 - $132 Set the dimensions of the work envelope.

Those are the key areas that I’ve had to change as I added stuff to my setup.


@_Michael thanks. I will check them all before I try to run again. Something weird happened and not sure why the z was inverted or why laser would be enabled, and reflashing still had z inverted.

Also I did install limit switches but have had them disabled for some weeks now.

1 Like

So I checked all settings found all seemingly ok, I reflashed z was inverted again. Does not make any sense to me, I think I will delete and reinstall Gsender, seems like I may have a bug.

Does switching the axis with $3 not work? Maybe the default is not correct.

Yes it does, however if I reflash then it reverts z again. Which I find strange. I ran a surfaceing again yesterday and all wa ok however I still have a gouge in the bed that I am unable to fully remove as it is below the t tracks. I tend not to stand watching the machine in operation I am normally about 30 feet away at my workbench so I am thinking when I replace the spoilboard later this week I wil wire a couple extra estops into the circuit, as well as reload gsender.

I may have inadvertently found the issue. I think that when I use 220v I am causing an issue with the longboard. I was running a long file today with the router in air I also had my main dust collector on, used the table and bandsaw and the my lathe. All of which are 220v. I got a unrecognised code error, and also had 3 disconnect errors.