Zero all axis when stop job

Why when stopping a program ( stop job) does the xyz axis switch to zeros? When I press the red button it should just stop without changing its position.

Please provide what machine you are using and what version of gSender you are using.

Yorahome 3018 pro cnc router and I believe it’s the latest version.

that router does not have limit switches, therefore if you stop in the middle of the job the controller defaults to 0 because it does not know where home location is

A CNC router for less than $300 and its the “Pro” model, too. (Czech Republic, also known as Czechia)

Perhaps limit switches can be added. Is there any way you know what the controller uses for electronics?

Perhaps Grant can comment on how his machine acts in the same situation? @gwilki

I added limit switches. I have to home the machine out after startup.

Is there a code I need to enable to switch the behaviour so it knows it has switches?

it is yes, i belive it is $22 in settings

There is a section in the manual about choosing to home or not to home. Part 4 Step 12 - Enable or Disable.

@B_rad_1983 @CrookedWoodTex @iuliancalin I cannot comment on your machine at all. I don’t remember what machine @iuliancalin has.

However, that is not the way that the Long Mill running gSender works. I do not have limit switches on my Long Mill. When I am running a job and click on the GUI Stop button, the machine stops where it is. The axes do not reset to zero. In fact, I can click on “return to XY zero” and the machine returns to my start point.

What sender were you using before you started with gSender? Did the same thing happen?

Yes same thing happened. UGS is what I used before and was hoping this one is different.

$22= 1 homing enabled

So that’s. not the setting I need.

I guess i need to have a backup plan for when I need to stop the program mid way.

@B_rad_1983 Since it did the same thing with UGS, it clearly is not a gcode sender issue. I didn’t think that setting homing was, either, but it was an easy thing to verify. Your best approach would be to reach out to support for your controller.

In the meantime, what are the circumstances where are you are stopping the program while it is running? Could you use the pause command instead? Could you set a second workspace so that you could still get back to your original XYZ0 after your stop?

The circumstances when I neee to stop will be usually when I need to leave the house. I normally do 3-4 hour cuts. So if I need to leave I write down my line and edit the Nc where I left off from. I home and am still good but I wanted to avoid that.

Does anyone else’s machine do this? Run a program and press stop job, see if the axis zero out.

Now I just noticed that there are two sets of numbers. Blue bold then smaller black numbers below for my axis. Since my project work from machine zero, I need to see if the bottom number resets as I’m not sure what the bottom number is lol.

I will do some more testing.

I will also try to set my G55 as a backup.

@B_rad_1983 I can only speak for my machine, but I seriously doubt that my LM is any different from any other LM. Hitting Stop does not reset zeroes.

In terms of your process, you could always simply hit Pause and leave everything on. No need to note line numbers.

If you are not comfortable with that, set your origin both G54 and G55. If you lose G54 with the stop, change to G55, go to XY0, then return to G54 and set zeroes.

Finally, have you tried using the “start from line” feature in gSender?


It might be helpful if, when you encounter this event, that you save/capture/write down the last of the console output. It may be that your controller is completely resetting or the equivalent.

There are also diagnostic reports that can be saved, but I’m not near my machine to quote the locations.

1 Like

@B_rad_1983 What CAM application are you using and what post processor are you using to create your toolpaths? Can you post one of the gcodes?

This shouldn’t happen on anyone’s machine.
How are you pressing “stop”?

It sounds like, as @CrookedWoodTex said, that your controller is resetting.

I don’t know what the problem is with your mill but I think I can explain the two sets of numbers for you.

The small black numbers are the machine coordinates. When you home the mill the machine coordinates are set to zero at the home position. The big blue numbers are the work coordinates, G54, G55, etc. The work coordinate systems are offsets from the machine coordinates. Because each work space is based on the common machine coordinates GRBL is able to ‘know’ where they all are in respect to one another.

1 Like