Zero point shift

I was wonder if anyone can point me in the right direction. I have a 2.5d carving that has failed twice now. The roughing path went perfect but the finishing pass with the 1mm tapered ball nose failed 1/2 way through the carve with a huge shift to the left. When I saw the shift I stooped the mill and told it to return to Zero and when it did, the zero was 2" low and to the left of the original Zero point on the lower left corner.
I carved the file successfully with a 1/8 ball nose straight endmill but both times with the 1mm tapered ball nose failed. I am using Aspire 9.5. Not sure where to start looking. Ant help would be appreciated.

When I first started I had issues with one of my y-axis wheels being a little loose and my anti backlash nuts needing set. This made the zero point move by more than an inch. This corrected the mechanical issues. Then there was a controller issue with UGS and CNCjs loosing signal just after starting, I finally went to bcnc and everything worked so was able to make my first stacked test sign.

I just had this exact problem. I too use Aspire 9.5 and the job had finished the last program (of course) and was headed to zero. Except that it continued left about 1.5" and bottomed out on the Z axis (I only have the top homing stop on the Z axis). The work was ruined and 1/4" engraving bit broken before I could reach for the STOP. Once I cleared the debris out of the way, stopped sobbing, and changed under garments, I reset and jogged the machine back up and the right of original on purpose zero and tried to RTZ with the same result. I was ready for it and hit STOP before the Z bottomed out. I successfully reset and homed the machine and now wondering if the robots are revolting. I have used Aspire for years with Mach 3 on three other CNC machines and a pickup winder I built with no issues of Zero shift. I could sure use some group brain power on this one. This was my 152nd gcode program run on the Longmill. I use UGS Platform. Thanks!

I had a lot of similar issues with UGS Platform Aug 2020 build. Through trial and error, found that ALL settings in UGS have to be mm for things to work. Most of my issues were with the touch probe not converting inches to mm and it would try to bury the bit 20 inches into the waste board.
Also, I’m using a 15 foot long hdmi cable for a 32" monitor. Switched from an old Win 7 laptop with 4GB of ram and slow video to a new Win 10 pro laptop with 16GB of ram and better video. No more random Z issues or random 3 hour finish passes not finishing. All has been running fairly smooth for the last month (knocking on wood as I type with one finger)

1 Like

I have been using the Aug 2020 build with no issues. I have never had an issue with my touch probe using inches. I never used it in metric, just measured the probe and used the observed values. There were seven separate tool paths all running from the same zero and it was only after the last tool path had completed and the machine was (supposedly) returning to zero to shut down did the issue occur. Mechanically, the machine is a dream. This is my fourth CNC machine and simplest by far (and fav until this event). I am considering getting a new cable set and going Gecko 540 and using Mach 3 like the rest of my fleet if I cannot figure this out. I really enjoy the Longmill and UGS but cannot abide by phantom failures This particular project was an alumium chassis and faceplate for tube mic preamp I am building for a client that will pay for the Long Mill and computer. I will be doing logos for my amps tomorrow and we shall see if it repeats the behavior. All dry runs since have been flawless and troubleshooting has been fruitless. Any help is appreciated.

I doubt this will help much but I was having random issue and discovered to use inches I had to make sure my cad and gcode were in inches, then my sender was told to use inches and finally I had to set GRBL controller to use inches and provide feedback to the sender in inches. Missing the last part had resulted in a lot of frustrating issues. ($13=1)

1 Like

I am happy to report I was able to cut 5 logos with no shift in zero. Each logo has three toolpaths. I changed absolutely nothing except end mills and collets. Interesting…

Yep, tinkered with the dollar signs. Just for out of the box ease of use and pure imperial laziness, I left all settings metric and all is well. I didn’t break anything yet. Using Aspire 10.507 so I can stack clearance tools so lots of tool changes and it just works. My imperial brain can justify the strange z numbers of 15-25 and not freak out anymore
it was fun watching that bit trying to go to -20 in" though, good smoke!

I’ve had my z axis magically lose itself in the middle of a cut. It’s cutting along just fine nothing changes but all of a sudden it’s slicing into the work piece, happened twice now. After the first time I tried again with no issues twice, but on the third time it did it again. I don’t know what else to check.

1 Like

Dan, I’ve had this happen quite a few times. In most cases I tracked it down to loose motor connectors, usually at the motor end. I think movement of the wires as they leave the drag chain must vibrate or tension the wires and the connector moves just a hair - it doesn’t take much - and the motor behaves erratically. It’s really dramatic when it happens on the Y axis and one motor goes positive and the other goes negative.

The last time it happened I did the usual connector check, and it did it again. I then spent quite a bit of time looking for something else. One of the forum wizards suggested a series of very slow manual moves in all 3 axes, and during the moves it was quiet enough to hear crunching noises which sounded like they were coming from the backlash block on the z axis. I replaced the block and it hasn’t happened since. I now it sounds far-fetched, but…

Good luck with your search for an answer. Please publish your fix if you find one - It happens enough that someone will be glad you did.

Thank you, I’ll check that out and report back.