Zero touch plate z depth zeroing problem

Ran a test on some pink foam on the 48x30 LM for a sign foam sign I will be doing. The project calls for 3 down cut bits 1/4, 1/8, 1/16. all running down to a depth of .2 inches (pocket cut). the 1/4 and 1/8 are clearing and the 1/16 is the final run. Using the autotouch plate, the 1/4 and 1/8 cut fine with no problems altho there was a collet change from 1/4 down to 1/8. When I zero’d the 1/6 inch bit using the autozero touch plate, it would only cut down to about .1 inch (was set up for a 1 pass .2 inch depth). Any ideas? Should I designate the size of the bit instead of using the auto feature for bit selection? Does it think I still have a .25 inch bit in there since I am only rezeroing the z at each bit change? When running ther 1/16" bit it seemed like it knew it was a 1/16 inch bit since it was basically trimming the letters but only going down about .1 inches.

@engraver99 Welcome back, Kevin. It’s not running out of Z axis movement, is it? With those short bits, it’s been know to happen.

No when I reset it and re-ran just that portion of the job it ran at the right depth it just seems when I run all 3 with just bit changes it just happens on the last 1

All is good in cnc land…deleted and ran new toolpaths with a 1/4 inch depth. Checked the z 0 (after using the autozero touch plate and all the depth was consistent for all 3 bits. reran the job and the final pass was cutting at the right depth. Glicth in the Universe, or maybe I missed something 1st go around. Was extra careful -and all worked well.

thanks gwilki - you can close this thread