Absolute 0 after homing?

Hi all. Just installed homing with limit switches and still have a few minor kinks to work out to shield the wires etc. But I would like to know if there is a way, (or a reason mine isn’t) setting the absolute 0 position when done homing. I’m set to home in the front left of the machine. Once done homing, it automatically calls this -795 -600 and -5 or whatever the numbers were. Basically it’s saying the “0” of the machine is supposed to be back right, and with the Z all the way up (my bounce off is set to 5mm, so this makes sense and is right).

What I would like to know is if there is a setting I can change to call my front left and the top 0,0,0? Then as I move right or back it counts up from 0, and as I move down it goes below 0. It would be much preferable to starting at -795 and moving right to -760 say.

Note I have a home built machine, not a longmill, though using many of the same parts.

@Andrew This is, I believe, fixed in how GRBL works. A choice was made, aligned with many industrial machine defaults, to set 0,0 as the back-right corner, and to operate in a negative co-ordinate space. Your working co-ordinates (G53 etc when you set zero on your workpiece) is then where your familiar/convenient positive co-ordinates come from and the motion commands (G0, G1 etc) work from this, so in effect you have what you are asking for.
Someone else may chime in and correct me, but I don’t believe you can alter where machine 0,0 is, if that is important to you.

Huh. Thanks for the info. It doesn’t matter much, just an annoyance of having to do math more often haha. Instead of having a start for a circle at 100,100mm, it’s now -595,480 or whatever matches the numbers +100. Thanks again.

I home to the left front for XY, with gSender, and the machine coordinates, the small numbers, are set to zero after I home. Then the numbers are positive to the right and back.

That is my understanding too. Machine coordinates are the raw, un-homed, underlying mechanism. Once you home the machine (via limit sensors/auto, or manually) you set the Working coordinates and gSender shows you both zero (as homed) and current position relative to home.

To clarify - standard GRBL (and industry) behaviour is that machine 0 is always the back right corner regardless of where you home to.

There is a GRBL option to set machine 0 at home location that is a compile-time flag - so not changeable once the HEX has been compiled.

All Longboard firmware (MKI/MkII) has this option compiled in for the behaviour that @Andrew is looking for - if he wanted this behaviour he can flash his board with either of those firmware profiles with the caveat that he should make sure to note his current EEPROM values

All Longboard users with relatively recent firmware(I think we changed that flag 1.5 years ago at this point) should see their machine 0 be at the homing corner.

As an aside, grblHAL exposes this as an EEPROM value so it should be a little easier to configure for the average user on the SLB.

2 Likes

On GSender, UGS etc, there are two sets of numbers for each axis. The small numbers ie. the -795 -600 -5 you are seeing are the machine datum coordinates. (G53). These are the position from the rear right hand corner. The large numbers are the Work offset (G54) coordinates.
When you home your machine in GSender, UGS etc. just zero the axis by selecting “Zero X”, “Zero Y”, “Zero Z” These will be the large numbers you see displayed. See the photo.


I always position my bit on the job and then Zero my X and Y axis before starting a job as that is where the program will start from. I set Z using a touch probe.

1 Like