CNC machine fails to run (Zero feed)

Hello everyone, since last week my custom build cnc machine fails to run g code generated from fusion, even somewhat older files i had around.
I don’t even know how to describe this, but, it runs if jogged manually on all axes as expected, i even updated to latest version of g-sender, i can use the new feature of go to xyz 0, all axes run simultaneus and go to expected coordinates.
It runs on the surfacing code integrated in g-sender as expected, but as soon as i try to run another nc file from fusion it fails, meaning the machine go to expected x y coordinates, z goes down to zero and the feed rate will display as 0. I have 2 videos on youtube unlisted, link bellow.
what i did so far, rewired everything, purchased a new controller board, i tried older version of g-sender 1.2.2 i belive. i also have candle and tried that software and it does the same thing, i unpluged uncessecary stuff like limit switches (inductive), those are behind relays.
the last thing i can thing about is the power supply, i have 2 one only for the motors, and one only contoller board, external switches for led’s and so on.
As the motors i have 4 nema 23 closed loop with CL57T external encoder.
Video 1 it is the surfacing →
Video 2 where feed rate plumets to 0 →

any help would be appreciated

Can you share the gcode?

sure, just not right how, since i am not at the place where i have my machine.
also that would be pointless since i had files that i already used months ago and i know those work.

any other ideas?

I noticed this in the software. This happens if I turn power for electronics off and on again.
This should only be a square contour, but there appears to be some lines. What is happening? It didn’t happen in version 1.2… of g-sender

Please share more to get help.

And your grbl settings.

ok fine, i’ll post the requested files, i’m finally at the place where i have my machine
please note, those settings worked untill now for a year long and just now started to act this way, the only thing i changed is the limit sensors from switch to inductive using a relay board, this setup worked too
i dont have any details for now but i’ll post later when i get home.
gSender-firmware-settings-9_6_2023-8_50_50 PM.json (725 Bytes) (779 Bytes)
the gcode file worked, i allready milled what i intended with it months ago

so i tried some more stuff and messed around with some settings in fusion, by default in fusion is set to “roll around the corner” that makes the motors to slow down and vibrate, but if i select “keep sharp corner” it does not do that.
also if i want to make a bore for example, that makes the machine to drop the feed.
i also tried a contour on a round shape from the file above and the machine does not go in circle, but rater makes the shape marked below, i can see the trace in the software too

What machine controller and firmware are you using?

not sure but i have a link to the board on amazon
also i changed the drivers on the board to DRV8825

Maybe GrblESP32? Can you get the response from a $I?
Anyway, I’d set your $1=255 to prevent the steppers from going idle after every move.

not sure what $I mean?
i did tried $1=255 and there’s no difference

Ok so I entered $i in console and got this

In your video, you can see when the feed rate drops the status goes to idle. This shouldn’t happen during a job with $1=255.
Looking at your settings again, why do you have $12 and $11 set to zero?


This might explain your issues as they are occuring on arc commands.

I don’t know what those setting are, so as I installed the new g-sender I left everything as it was, I’ll try to set those to see if it works.

I tried and I can set $11 to 0.01
But $12 only accepts 0.01
Also that works but I feel like the feed is slower than it should.
Also I forgot to mention, sometimes the machine stops in the middle of the job, or goes to the end and stops. Where it should retract to clearance height.

3rd edit: I reinstalled 1.2.2 and it works !!! :confused::face_with_raised_eyebrow:

1 Like

Can you share your current $$ settings?

All I can guess is that you have a non standard version of Grbl and your settings within that are odd.

It works again :smiling_face_with_three_hearts:
I reinstalled version 1.2.2, the last version I tried was 1.4.4 it didn’t work on 1.4.3 or 1.4.1
And yes I do believe now that it had to do with $11 and 12, I can see both set to 0.010, this was something i never messed with.
I will post my $$ output shortly since I started a project from fusion to test.

and as promised here are my settings exported from version 1.2.2
client $$
$0=10 (Step pulse time, μs)
$1=255 (Step idle delay, ms)
$2=0 (Step pulse invert, mask)
$3=2 (Step direction invert, mask)
$4=1 (Invert step enable pin, boolean)
$5=0 (Invert limit pins, boolean)
$6=0 (Invert probe pin, boolean)
$10=3 (Status report options, mask)
$11=0.010 (Junction deviation, mm)
$12=0.010 (Arc tolerance, mm)
$13=0 (Report in inches, boolean)
$20=0 (Soft limits enable, boolean)
$21=1 (Hard limits enable, boolean)
$22=1 (Homing cycle enable, boolean)
$23=0 (Homing direction invert, mask)
$24=50.000 (Homing locate feed rate, mm/min)
$25=800.000 (Homing search seek rate, mm/min)
$26=250 (Homing switch debounce delay, ms)
$27=2.000 (Homing switch pull-off distance, mm)
$30=0 (Maximum spindle speed, rpm)
$31=0 (Minimum spindle speed, rpm)
$32=0 (Laser-mode enabled as spindle, boolean)
$100=1603.651 (X-axis travel resolution, step/mm)
$101=1603.651 (Y-axis travel resolution, step/mm)
$102=1599.492 (Z-axis travel resolution, step/mm)
$110=2000.000 (X-axis maximum rate, mm/min)
$111=2000.000 (Y-axis maximum rate, mm/min)
$112=2000.000 (Z-axis maximum rate, mm/min)
$120=750.000 (X-axis acceleration, mm/sec^2)
$121=750.000 (Y-axis acceleration, mm/sec^2)
$122=750.000 (Z-axis acceleration, mm/sec^2)
$130=553.000 (X-axis maximum travel, mm)
$131=553.000 (Y-axis maximum travel, mm)
$132=120.000 (Z-axis maximum travel, mm)

That makes sense. I don’t think gSender would just change those values, though. They’re stored on your controller.
Well, I’m glad everything is working. And I’m glad you eventually shared the information needed to solve this.

alright, so i finally figured what could be the issue.
i installed gsender at home and plugged the same but damaged board, the chip is fine, it’s just a connector that i burned for limit switches. the board works fine other than that
so, apparently i can’t apply the settings on $11=0.010 and $12=0.010 i can only apply on both 0.01, might be a bug?
i can apply the above settings on older versions up to 1.4.1
it does not work on 1.4.2 1.4.3 and 1.4.4RC1
i can try tomorrow with the version 1.4.1 and come back with the result
it would be really nice if i could make it work on 1.4.2 at least since i have a 3d probe that i use to find stock corners