Dropping z depth

I’m having a hard time with my machine. Very frustrating. The z depth increases throughout the operation. The first cut is OK, but at each new cut the bit enters the wood at a lower depth than the previous one. Forexample the depth is set at 1/8 th. On repeated passes the depth can go to 3/4 of an inch. I’ve checked the code and it is fine. I’ve ensured that the bit has not dropped. Redrawing the image makes no difference. Carbide create and Carbide create 5 are used to generate the code. Even if there is no bit change, it happens. I’ve tried re zeroing to no change.

That is not correct and while it is happening, nothing you mill will be accurate.

Good news! That demonstrates that you are setting up the cuts correctly.

If you are using a trim router, this can happen with incorrect tightening of the collet around the bit. The usual reasons for incorrect tightening are not cleaning the collet nut, the collet and the collet taper after every single job. It also means cleaning the tool bit too. Not knowing how much pressure to apply when tightening the collet can also be a problem.

I will assume you are using a Makita trim router. These come with two spanners (wrenches) and it can make you life easier if you use them together. Do not press the router shaft button and turn the collet nut with just the large spanner. This applies uneven pressure on the router and can impart a tilt to the X rail or the Z carriage.

To tighten the collet nut apply the small spanner to the router shaft key and apply the larger spanner to the collet nut. Both spanners should be held in your dominant hand and the spanner shafts should describe a V shape of around 30 degrees. The large spanner should be on the left of the V shape. Squeezing the two shafts together will tighten the collet. Undoing the collet is a reversal. The larger spanner should be in your hand on the right and squeezing the two shafts together will undo the collet nut. Your free hand can hold the cutter.

Accuracy issues derive from three areas. Hardware, Software and User. Take one step at a time and really examine the hardware. If you are using a lead screw driven machine, you should look at the tension of the screws and the backlash compensation accuracy. It is unlikely to produce large error of 5 x more than your specified pass stepdown but I would check the assembly of the machine from start to finish. One possibility is that the tension of the lead screws is so tight that it causing your machine to lose steps in the Z axis.

My machine gave me accuracy problems after I had spent three careful days assembling it. In the end, I had no choice but to dismantle it. I then spent 6 weeks rebuilding it once I had understood the factors that can produce inaccurate cuts. I am saying that you first job is to eliminate any possibility that you have assembled something that is causing the problem. It is time consuming but you will only ever do this job once.

Software can be responsible for unexpected behaviours. I initially used Carbide Create and Carbide Motion. This was a natural move because I had purchased a Carbide machine. Ultimately, I dropped Carbide Create because it was very elementary and used lots of design methods that were not on all fours with standard design programs and the expected conventions.

I moved to Carveco Maker because I wanted to be able to mill true 3D and Carbide Create could not do that without buying the professional version. That version was really janky to use and I could not bear to pay good money for something that operated in its own unique way. I have not used it for about a 14 months now so I have no idea what it contains and how easy it is to use.

Carbide Motion is a different animal. I and other people I have known have suffered with random unspecified Z axis plunges that are very dangerous. I still have a ticket with Carbide 3D for this dangerous behaviour but they have never addressed it. I was delighted to find gSender and note that it is a much better piece of software. It is very well written and the user interface is streets ahead of Carbide Motion. If I could give you any advice that would improve things for you, it would be transfer your motion controller needs to gSender.

Now the user is the one variable that all manufactures of hardware and software cannot account for. If you think of this irritating issue as a puzzle, you are halfway to solving it. Specify a square of 1/8th deep. cut it and measure what you have. Is the square the correct size? Is the depth the correct depth? Next add the step down so that you cut 1/8" twice. You square should still be the same size as you specified but the depth should be 1/4" after the two passes in your stepdown set up.

FWIW, I remember using Carbide Motion and setting the stepdown when selecting the tool. If you remember to set the total depth at the next step, I recall that going back to the tool selection box would see the stepdown value changed. If that has not been fixed, that could be responsible. Whatever tests you run, it should be something you note down meticulously so that we can assist you.

hell Jeffrey
thanks for the information. I have used all your suggestions (quite good), but the problem continues. It seems to happen in a pocket operation. I use gsender for my CAM operation. Also used was ugsplatform from scienci. All nuts and bolts were check too. I marked the bit to see if it dropped during the job. It did not. My final guess the errors may be caused by he controller. Maybe?
I’m running out off options. I have lost 2 paid jobs because of this error.
thanks again

Hi Larry. OK, can you say what happens when you run a profile or contour operation?

Did you try cutting a square of known dimension with a pocketing operation. e.g. Cut a 2 inch square 1/8" in depth. Then cut another similar 2 inch square 1/4" deep (use 2 x 1/8" passes for your stepdown). Finally, cut a 2 inch square pocket 1/2" deep using 4 x 1/8" passes for the stepdown value.

This should produce three identically sized squares, each at different pocket depths. You will want to see that each square measures the same dimensions as the others. The reason for three different ones, is to see if the step within the controller is what is out. You will use 1 step, 2 steps and 4 steps. This will indicate whether you are losing steps on the Z height stepper motor.

Loosing steps in the Z axis stepper is one certain cause of increasing depth of cut.

Before implicating and ripping out the controller (which wont help you if the stepper is loosing steps) just try this test and report back.

@bubalarry Post the gcode please.

hi: thanks for taking the time to help me. Below are the codes for the project as per your request.

bubbalarry.txt (21.2 KB)

Also i have included screen shoots of the project.

hi jeffrey
While watching the console in gsender, I noticed that the values for z were plus amounts when the bit plunged into the wood rather than at 0. Z was zeroed at the beginning of the project. I have looked over the coding and dont see where it occurs in the code. Could this be a stepper problem?
thanks again for any insight.

1 Like

@bubalarry I’ll take a look at the file, Larry. I deleted the 1568 lines of code in your post and uploaded them as a text file, just to keep the post cleaner. I have not done any editing of the file.

1 Like

@bubalarry A couple of things:

Here are the z moves in your file

larry Z moves.txt (708 Bytes)

You can see that Z does not lower to 1/8" until line 948, more than half way through the file. That is the deepest that it ever gets.

Question: In Carbide Create, where did you set your Z0, top of material, top of spoilboard? In gSender where did you set Z0, top of material, top of spoilboard?

Hi Larry. I will await the deliberations of Grant. It looks as if he as found an issue. Let’s await the outcome of Grant’s deliberations first.

good morning: in gsender i set z0 at the top of the material. The problem occurs in all projects. That is, in gsender software, the z amount is a plus as it enters the wood. It should be z0 when it touches the wood. Shouldn’t it? However, the code console readout in sender says that the z is zero, but in the xyz location box, z has a plus number.

good morning. i did the 3 pocket squares. The depth of cut was more than the gcode shows. That is, in gsender software, the z amount is a plus as it enters the wood. It should be z0 when it touches the wood. Shouldn’t it? However, the code console readout in sender says that the z is zero, but in the xyz location box, z has a plus number.

Hi Larry, It’s early evening here. OK, now we are getting somewhere. First was each of the machined squares the exact size which you specified in the X & Y dimensions?

good day
The size on x axis was perfect. But Y was about 1/16 shorter.
Yesterday, I sent gsender back to default. No change to the problem. The z mechanism was examined and seems to be as per assembly instructions. Wiring and dip switches are correct.
I tried ugs platform to see if a different program would help. Nope.

@bubalarry In re-reading all your posts, I finally saw something. Are you saying that positive Z gcode commands cause the router to go down? If so, is this just in gcode or when you click on the up Z gui, the router moves down, too?

Has the Mill always done this or is this a new thing, Larry?

This is an issue. While not obviously connected to the Z axis, it will raise its head again when you try to make anything meet the sizes you have specified. One reasonably common answer to this is the X rail not moving squarely along the two Y rails. I don’t have your machine so cannot tell you the correct process for squaring the machine in this way.

On my own machine, I found that one side of the X rail was meeting the endstop before the other side (about 1/8th" out) and it left a slight gap at both the front and the back of the machine. It was the front left that was not meeting the endstop and the rear right was mimicking that behaviour. Once I had ensured the squareness, the issue was solved. I loosened all of the endstop bolts and pushed the X rail into the correct position then held it and then tightended all of the bolts.

This is a frustrating thing to address, Larry. If all is set up correctly and the software makes no difference, it points to a hardware issue. A simple (if tedious to carry out) check is to exchange the stepper motor on the Z axis for one on the Y axis. If it is a hardware fault with the motor (not unknown) then the Y axis should reproduce the fault and the Z axis will clear.

Can you be certain that all of the lead screw nuts and bolts are tightened to the identical torque and the everything moves freely?

Well I bought a z stepper motor. Problem fixed. Yea

1 Like

@bubalarry Really glad to hear it, Larry. That’s a new one on me.

As the original issue has been addressed, I’m closing this topic. If anyone else has a similar concern, feel free to start a new topic, which will ensure that it is addressed promptly.