First ever cut ... could be better news

@oxbowbob Bob: You should see arduino uno in your device manager. It seems that windows is not loading the drivers. Arduino.inf should be on the drive where you OS is. I don’t know why windows is not loading the drivers, but you can install them manually. Search on arduino uno drivers for windows and you will find instructions and the drivers.

My oh my OH MY. What’s your address … I gotta send you a box of chocolates … a Starbucks certificate … new socks … something!

I was watching a youtube video by BobsCNC about installing the drivers when you responded. Once the driver was there it was pretty simple. Had a little trouble loading the .zip. BUT … for the first time in days I jogged the LM just now.

Soooo now … can’t wait to see if this thing stalls mid surface again.

What do you think of this? Set Z zero above the wasteboard so when I run the surface it’s only going thru the motions and not actually cutting anything. That should work, right?

Again … thank you all for taking the time to help me.

1 Like

@oxbowbob Yes!!! I’m glad that things are progressing, Bob.

Your idea to “cut air” is a good one. When I was trying to figure out why my Mill was freezing, I did that quite a bit. I would suggest that you try one project with the router and the dust collector running. If it freezes, try again, but turn off the dust collector. If that works, you know where to put your time. If it freezes still, turn off the router. The key is - and this is not what I did - change one thing at a time. That sounds like it should be obvious and it may well be to you. But, I didn’t do that, so figuring out what the problem was took more time that it needed to.Obviously, if you have issues when cutting air, you can progress to actually cutting something. Follow the same progression.

Oh, one other thing since you don’t know why the gods have been beating up on you, look at your windows updates and do not let mother microsoft update drivers when it updates windows. That could be what caused all this grief. Good ol’ bill gates and co decided to push a driver update that arduino didn’t like. This happens often with windows updates. I maintain several pc’s for friends and colleagues and have found over the years that MS almost always messes up when it plays with drivers.

Have fun, Bob.

Just so you don’t think I forgot about you … I ran 3 dry runs tonight and didn’t get one freeze. Router and dust collection don’t seem to be an issue. I also wiggled the USB cable like crazy. So much that I couldn’t believe it didn’t stop it. That cable is fine.

Now that isn’t saying there weren’t any issues. When I first went to run the tests I turned the controller on and got a little static electricity shock. A couple noises came from the mill & UGS wouldn’t connect again. Arduino was missing from COM3. I unplugged the the USB cable and plugged it back in and the driver was reinstalled. Then I ran the tests. As I shut everything down for the night I got another shock. I had to check. Sure enough it wouldn’t connect again, but a repeat of what I did before got it all back.

So what do you think of this one, Miyagi? :smile:

@oxbowbob Where are you getting the shock from?

From the controller case.

@oxbowbob That’s odd. Does it seem like a static “shock” or is there DC voltage leaking somewhere? When do you get the shock, when you are turning it on and off?

Absolutely static and when contacting the case.

@oxbowbob Ground it. It’s odd that you would get static on the controller case. There is no air or material movement that would generate it. However, since it’s there and causing you problems, run a wire from the case to ground.

This is getting old. 4 more stalls/freezes today. I got 3 full test runs cutting air. The next three surface cuts stalled. I got 3 more full air tests cut after the stalls! It just stalled again (4th) on a actual surface run. The only common denominator is the router is down instead of up. Not necessarily cutting … just down and going over an already surfaced path.

Only good news is that the tram is awesome.

Can a running router cause this???

I didn’t get shocked today and I didn’t get around to grounding it yet.
I checked every power saver I could find.

When it runs OK, is the router on?

What about dust collection?

It has never failed with router & DC on while the router was up and not cutting. It has only failed with the router down & in position to cut. I mean I guess that has to be coincidence because it just doesn’t make any sense. HOWEVER … in 7 attempts to surface it has not made it once AND it has made it 9/10 times cutting air … in all different configurations and not failed once.

I just went out and put a fuel pump on my lawn tractor. It felt good to fix something! :smile:


I have this pair of polyester sweat pants I usually slum around the house with. I had them on downstairs trying to get this mill to do what I want instead of what it wants. I walk by the controller and I hear it beep thru my pc. Sure enough it’s disconnected. I didn’t touch it … I only walk by it. Had to unplug USB cord to get it back online. This happens 2 more times and I notice if I touch any other equipment (none had been running in weeks) in the shop I get a static zap. I stopped wearing those pants and it hasn’t happed since. I was hopeful this was the cause of the stalling wasteboard cuts. Not so lucky.

I was side tracked for a few days trying to learn the software and actually cut some small projects. That was a lot more fun and they all ran without an issue. I decided to try the wasteboard again today. I moved the controller from the table side to under the table thinking there would be less chance of static. I ran the surface program and made it a little more than twice as far as normal before it froze. Today it was quiet in the shop and I hear a very low volume noise coming from the mill. I put my ear to everything I could but couldn’t really determine where it was coming from until I started feeling things. One of the motors on the Y rail was making a barely audible hum but I could feel it better than I could hear it. I tapped it & wiggled the wires. The only way I could get it to stop was shut off the controller. Below is a picture of the error code. Does it mean anything to anyone?

I cleared everything and ran the whole surface program again. Nothing was moved or touched. The only difference was the router was cutting air. It ran all the way to the end without a glitch.

I checked the grounds on all the receptacles. If the cutter and mdf are causing the static, where/what do I start trying to ground? Would a plywood wasteboard help?