g-Sender 6.5 Beta Windows -unable to disable homeing

I am trying to play with homing on my longmill

I am running into all kinds of issues, I will be verifying things and reporting them.

However, I feel this issue is an easy one to report.

When enabling Homing, in the firmware everything seems to work
however if you try to disable homing, and save. after reconnecting, the variable is restored.

using the console, seems to work just fine.

steps to reproduce :
Click on Firmware.

change the following values
$5
$22=1
$22=3
$27=5
$130=812
$131=812
$132=105

click on Apply new settings
wait for “completed” message

type $$ in console and verify settings have changed.

exit gSender

Open gSender
do not clear the error code (not sure if this is required, but this is how I did it)
open Firmware menu
Change $22 to 0
click on Apply new settings
wait for “completed” message
exit gSender
Open gSender

At this point, there should be NO ERROR POPUP as homing is disable. however look at the firmware page and you can see $22 is set back to 1

in the console
type $22=1
type $x
exit gSender
Open gSender

note that there is no longer a error indicating homing is required.

note:
I am also investigating a problem, where after homing in gSender, the error pops up and wants to continuously home, however, I havent confirmed this, it was late.
as well, this seems to work just fine in UGS

fyi: I am using this thread to setup homing

noteable diviations
1 - I am using headphone audio cable instead of the 22 gauge used in this thread.
2 - Author is using a .47uf capacitors instead of the recomended .1uf from this thread
Adding Limit Switches - Documentation

1 Like

@Menglor I think this is coming from the fact that firmware changes aren’t normally registered when the machine is in a locked state. Perhaps we could make some changes to the behavior of the firmware window to not allow access while locked so that there isn’t confusion about this

Functionality that the firmware button offers is annoying because it doesn’t work but you can use the $22=0 and it works

I’m just reporting the issue

@chrismakesstuff

Tested in 0.6.6

seems to be working fine.

1 Like