Gamepad/Joystick Support

I haven’t had luck with my controllers straight out of the box either, and though I haven’t had the chance to test with the latest build, there are a couple of things that have helped me out along the way:

If you didn’t know that there are two different control protocols you can use with the logitech controller, you can trying switching between X input and Direct input to see if it likes the other one better.

That link in particular may not be helpful to you, but my PC didn’t recognize my PS3 controller, until I downloaded this “wrapper” that makes it appear as an Xbox controller, which the PC likes much better. There may be an equivalent input wrapper for generic (or even logi 710 specific, I know they’re pretty popular), that you might have better luck with.

This was reported on the FB Group , I have reproduced it.

Using a SNES Joystick Controller. (amazon.ca Clone)

Added Profile : Controller (vendor:0079 Product: 0126)

Go into profile.

(working)
Click + for Zero X Axis
(note: Waiting for button press) is displayed.
press the X button
(note: Button press detected displayed, Last button pressed : 0 displayed.)
Ability to type name. and SET button enabled.

Click + for Zero Y Axis
(note: Waiting for button press) is displayed.
Press the D-PAD Down button
(Note: No button press detected, no screen change, unable to name shortcut. Set button disabled.)
Press ANY button on the controller, except the Dpad, and it registers a button press.

BUG!

Controller used:

1 Like

@Menglor, just going through bugs today and came across this one once again. We don’t have the same model controller on hand for testing but I’m wondering if the couple tweaks we made to the joystick handling has fixed this issue or if it’s still not functioning?

Thanks,
Chris

SO I have the SNES controller and a Xbox controller.

I just installed 7.2

using the SNES controller, the D-pad does nothing when recording the button presses. (X ,Y,A,B ) buttons do regester as expected.

using the Xbox Controller, the D pad registers all 4 buttons, however the 2 Thumbsticks do not register any presses (D-pad and XYAB buttons do register button presses)

1 Like

Ok, we’ll spend some more time at it :+1:

I have tried 2 xbox usb controllers and have little luck with either. There were several issues and inconsistent results with gsender version 7.1 and 7.3. I had hoped the latest version I installed 7.5 would resolve some issues and work better. Unfortunately the results are not as good as the previous versions.

Though, the joysticks are no longer captured when trying to set up. Other buttons can get set up, but when used do not work. I can get the z- button to move, yet the z+ button also moves in a negative z direction.

After continuing to play with the xbox controller I figured a couple things out.

If I press and hold the button or joystick nothing happens.

If I press or move the joystick for a moment and release, then the the associated action will take place.

Also the joysticks on the control are not programmable and default to x and y movements.

1 Like

Hey Folks,

As @NeilFerreri mentioned there were some issues with the continuous jogging when assigned to a button on your gamepad. In some situations when releasing the button the continuous jog would not stop as intended and keeps moving, which is obviously problematic and causes us to hit the emergency stop button. In the stable version of gSender that was released last Friday, I have addressed this issue and did some testing on it to make sure I could not replicate that bug again. If you guys want to test that out and let me know if that issue still persists please feel free! Thanks to all who have given me feedback so far as well!

Cheers,
Walid K

1 Like

Hello,

I am trying to use a " SQDeal USB Wired Joystick Gamepad"

I only get motion on the x- axis while using the analog button. It only moves in the x negative direction. No other buttons seem to cause any reaction. I am also on a Raspberry Pi 4. With the latest downloaded version as of a couple weeks ago. So roughly (11/15) time frame.

Is there a list of Gamepads that currently work? I would like to get one and try it. I would prefer a wired unit if there is one known to work on the RP 4.

Also great software. I think by far the best sender out there!

Thanks,
Mike

Hello,

I have the SNES controller and trying to control jogging in Gsender. The buttons on the controller work (ABXY) but the direction pad (D-pad) doesn’t register when trying to assign it under the shortcut menu.

Thank you
Nick

2 Likes

A post was split to a new topic: Xbox 360 controller use in gSender

Hello all,

I’m wondering if it is possible to use a pendant controller on the Longmill? I use Easel Pro and a Mac laptop.

Thanks,
Andre

If you could find a pendant that works with GRBL. Maybe.

Otherwise a USB joystick works great

2 Likes

What about the Playstation controller? I haven’t seen it mentioned. Could it be compatible?

Might work. But PS controllers are blue tooth

Yes. Okay. Thanks for that input.

Tried to connect to that link but it said it doesn’t exist or it is a private page…

Hey @walid_kayhan do you have a video for setting up this Logitech F710 from start to finish? Just got mine today. Video might be handy or point us to the link if there already is one.

Hey @RickW,

I don’t have a video setting up a Logitech F710 or any other gamepad/joystick on gSender at the moment, but that does seem like an interesting and useful video to have for the people who want some additional help and clarification with joysticks setups, and I will definitely consider making a video in the future if that’s what you guys really want!

Walid K

thanks @walid_kayhan
Got mine set up but required a little tinkering.

1 Like