gSender 0.6.7 Release!: Feedback Thread

Another bi-week another release. This time it’s be a tri-week since the previous release since I gave the team a week to pursue their own concepts and ideas before jumping back into the dev sprint. Let’s take a look at the new changes: @all

https://github.com/Sienci-Labs/gsender/releases/

What’s new?

  • New Movement Tuning tool that can be used to calibrate motor axis movements
  • New feature for running G-code at program Start and Stop - enter and save your own commands in the settings
  • More exposed keyboard shortcut options and new categorization
  • Now able to assign shortcuts to macros!
  • Added coolant buttons and status indicator
  • Better M0/M1 command support - notification in the UI when command encountered and easier to resume the program
  • Clearer visualization due to reduced rapid line opacity
  • Improvements to the surfacing tool limits and settings persisting
  • Ability to reset gSender settings to default
  • Added reconnect logic to client to reduce instances of UI no longer updating on long jobs
  • Fixed an issue where the “Home machine” button wouldn’t disappear on homing cycle
  • Fixed an issue where macro exports were unable to be re-imported
  • Fixed issue with jogging while $15 was enabled
  • Other minor bug fixes

Things we’ve got our sights set on for the next release:

  • Still more improvements to performance by streamlining data parsing and manipulation to improve reliability and reduce possibility for data leaks (enabled worse hardware to run larger files more reliably and smoother operation of gSender as a whole)
  • Joystick control
  • Run outline prior to job operation

Topics I’ve noticed feedback on that we’ll be looking to address soon:

  • Headless Pi operation
  • More guidance for first-time users
  • Start from a specific gcode line to save projects gone wrong
  • Manual value entry for X, Y, and Z locations

This was another super productive past two weeks for the gSender development team. In addition to all this, we’ve also got a new location to store all the documentation if you’re looking to learn more about gSender and how you can use it (guidance on new features will be rolling out over the next two weeks):
https://resources.sienci.com/view/gsender/

If you’ve encountered any bugs or have feedback on this new release, let’s discuss!

Happy Thursday everyone and happy Canada Day :beers: :maple_leaf: :maple_leaf:

2 Likes

“Start from a specific gcode line to save projects gone wrong”

++++++++++!!!

1 Like

How does that work? I don’t see any way to define your own keyboard shortcuts. That’s the feature I’m most missing,since I use Touch Control to send keyboard strings to GSender from my iPad mini. Without keyboard shortcuts macros are not useful yet.

If you go to Settings → Keyboard Shortcuts and scroll to the bottom of the list, you’ll see any macros you’ve currently created in that list and you’ll be able to assign a shortcut to them :slight_smile:

Unfortunately this doesn’t seem to be true.I’ve attached a shot of the shortcut dialog and the macro dialog - the ‘X+10’ macro isn’t present… I even pressed the ‘enable all’ button in case that was needed to update the macro listing. :sleepy:


3Jul21_MacroList

Chris, I don’t know if it was the heat (35-40’C) in the shop or g-sender but when I tried Ver0.6.7 on my RPI4B the time lag between g-sender & what the longmill was doing was well over a minute in duration, also noted that it was running the longmill at 2/3 feed speed. It then locked up with the longmill back at zero with job done but screen showing only a 1/3 completed. I the reverted back to V0.6.4 & it ran first 2 files fine but when I went to run third file it decided to offset 2 of the 4 tapered holes I was doing. On the fourth file which was to create 4 hollows around the tapers it also decided to a) lag & b) cut one of the hollows twice as deep as the others. I thought maybe due to the heat it might have been the Pi but I didn’t get a high heat warning & also have a fan in that unit. Today with a cool 30’C I tried V0.6.4 again running the dish file & had same issues. Finally I ran 2 of the files with UGS & it showed no issues. I’m going to revamp the files to try & save the folding wine table I was making & retest again with a fresh RPI OS & latest version.
UPDATE: I managed to set up a new OS & using Ver. 0.6.7, did up 3 files to salvage project & noted the following:

  • had to reboot after running each file as file wouldn’t load into visualizer.
  • First file screen froze at 9% done. Gcode/router ran complete code. Had to reboot when done.
  • 2 & 3rd files: time lag between what screen showed & router position at finish was just over 1.5 min.
    Ran last file in Lite mode, no difference in gsender time lag.
    First image is 1st file frozen at 9%. Second one is completion of cleanup files. Just a bit of sanding & folding legs to do…

    (upload://gOSiPQABvUSemkc4GpI2UNMlO7P.jpeg)

    This is what a finished product looks like

Russ

Further experiments in assigning shortcuts to macros: (1) I tried various macro names including special characters, with no change (they weren’t visible). I created 3 macros with simpified names [right10, right1, right0.1] with no luck. I tried deleting the check on/check off macros [which don’t work well in any case] and my 3 macros were visible! I then tried creating another macro [left10] but it was not added when i went back to the shortcut dialog.
This is just not reliable at this time, and I can’t find a real pattern to the problem. :sleepy:

1 Like

Keyboard mapping seems to have gone off the rails. :grinning:

Some work, others don’t. None of the jogging keys work. Start job does not work. Some of the axis zero keys work, others don’t. The jogging on-screen buttons work UNTIL I try to use a mapped key. Then, when I try to use an on-screen button, all I get is a noise. I’m guessing that jogging has somehow reverted to a very small feed rate.

I uninstalled 6.7 and re-installed 6.6. The problem persists in 6.6. Before installing 6.7, all my mappings worked perfectly.

I believe the macro files are located in :
C:\Users\ ??? \AppData\Roaming\gSender \ “gsender-0.5.6.json”

I suspect if you want to change version, you might need to clean up that directory

1 Like

I use the gSender on a Macbook Air. When the laptops screen goes dark and into sleep mode, the machine stops running, I did not have this issue with previous beta versions.

1 Like

I just wanted to mention, that Using Shortcuts, when you have the MACRO TAB in focus , doesnt work.

at least from my experience.

I fully uninstalled 0.6.6 and deleted the gSender folders in ApplicationData in the USERS folder.

I created 5 macro’s and created shortcuts CTRL 1 - 5. and it all worked fine.
Except when I had the Macro tab open, all bets were off.

Just something for you to try.

@chrismakesstuff

Macro question! where are they stored?

Today, because of the problems people where having, I though I would be smart and clear out 0.6.6

  • uninstalled 0.6.6
  • deleted
    D:\Program Files\gSender
    C:\Users\stephen\AppData\Local\gsender-updater
    C:\Users\stephen\AppData\Roaming\gSender

and then I installed 0.6.7

When I launched 0.6.7 I noticed my macro’s where still in the UI.

so my question, is where is that info stored?

Macros/events are stored in .sender_rc, which should be in your user directory (C:\Users<Your User Name>.sender_rc)

2 Likes

@KGN Kevin: Are user defined macros and user defined key maps stored in the same place?

I just looked at the .sender_rc file and it appears to only contain the macros, not the keymap.

1 Like

No - keymaps/general settings are in the .json file, macros/events are in .sender_rc.

1 Like

@KGN Tks, Kevin. I found them. I’ll write another report, as they are not functioning as they are written in the json file.

Addendum to my previous post about keymapping.

I have played more and found the following:

I have the “-” key on a wireless keypad mapped to Y-. The key mapping screen shows that is the case and the .json file does, too. However, tapping that key does not jog the Mill in Y-. Instead, it reduces the “xymove” and “speed” as indicated in those windows just below the jog screen. The presets for normal, rapid and precise are not changed.

Now I know for sure that the noise that I was hearing was simply because I had pressed the “-” key on the keypad enough times to reduce the step size and speed to very small values. The Mill was moving, just so little and so slowly that I could not see it move.

Hey folks - we’re attempting to fix an issue with the load file button not working. If you have time to go to the following link and follow the steps, it could hopefully help us resolve these issues!

Hey Grant,

Could I get either a screenshot or a list of your keybindings for play/jog/etc. if they aren’t default to follow up on this? We’ve found an issue where keyboard ‘-’ and keypad ‘-’ being able to be set separately since they’re different keycodes but routing internally to the same action. Was hoping we could find a similar issue with your other non-working keybinds since default binds are working on our end.

Thanks,
Kevin