Gsender 1.0.0 Z zero

When zero using the touch plate or without, the X and Y zero appropriately, however the Z will zero out, but will not return itself to zero. It just stops where it raised up in the process of returning to zero, however, does not actually return to zero. Help.
I ended up reinstalling 0.6.5 and updating to 0.7.1 to get my carve underway.
I really liked the new look, but I am not sure if there was something in the settings that I am missing… or it’s just a glitch.

How are you sending the Z-axis to its zero?
It doesn’t need to be at zero to start a carve…none of the axes do.

1 Like

@chapklc Kari: To follow up on @NeilFerreri question, how are you returning to zero. For the last few versions of gSender, the “return to xyz0” button has been changed to “return to xy0”. So, if you are using that button, that will be why it does not return to Z0. As Neil said, though, you don’t need to return to any of the axes’ zero before running a job.

I was actually doing a bit change.
Completed the Z zero with the touch plate.
I always press, go to xyz zero, just to be sure I didn’t mess anything up, then I resume my job.
Usually when I press go to… the router will initially lift, return to zero, and lower down into the appropriate location.
This time, with the version, the router lifted, moved into X Y position, but did not return to the Z zero. Does that make sense?
Further testing just the z zero… I pressed go to Z zero. It stopped in the exact same spot it did when I told it to return all to zero. It was like the Z zero was not zeroed.
I had noticed that the new version has settings for standard xyz touch plate or z probe. I had it set for standard. I did not see any other settings to change.

@chapklc Kari: That is the way it is supposed to work. You will see in gSender that there is no longer a “return to XYZ0” button. It has been replaced by a “return to XY0” button. If you want to return to Z0 also, you must do what you did and press the “go to Z0” button. This prevents the bit from hitting clamps, for example, which was an issue with the previous set up.

The settings for the touch plate have not changed. You can used it to find each axis individually or X and Y, or X,Y and Z.

Ok, but when I press go to Z zero, it did not return to the proper place.
It stops about an inch above where it should be.

@chapklc Gotcha. OK, what does it do? So, you set Z0 with the plate. The bit rises at the end of the process. You hit “go to XY0” and it moves to the correct place. (This assumes that it moved at all after using the plate.). Then you hit “go to Z0”. What happens? Does it move at all?

If it does not move at all, one thing to look at is that you are hitting the “go to Z0” button and not the Z0 button. No offence meant. But since they are pretty much butted together, it’s easy to hit the wrong one and simply reset Z0 to the current position.

It never moved to the correct Z Zero position, not when I did a X Y Z zero, nor when I changed bits and did a Z Zero. It will return to the correct X Y zero, but not Z zero, stopping an inch or so above the board itself.
And I only use the touch plate, I don’t zero any other way…

and no offense taken, I have in the past hit the wrong buttons. My hubby was over my shoulder making sure I was doing it correctly.

I’m in the middle of a carve when gsender 0.71, so when that has completed, I will load the 1.0.0 version and try again. I will maybe video what I was doing.

@chapklc I only mentioned it because, on the rare occasions when I don’t use my keypad, I have hit the wrong one more than once. The issue for me is the design of the buttons. The small blue rectangle is the “go to” button. The larger white button right beside it is the “Z0” button. It’s been this way since at least .7.3 and maybe earlier, too.

I’m attaching a bad graphic in case I’m not making myself clear (not unusual)

Z0

2 Likes

LOL, I do, actually, understand… :))

gSender 1.0.0: Example, just tested in isolation after fresh start:
If I am at X=200, Y=0, Z=30 and press GoToX0, it ends up at X=0 AND Z=0.
Caused a crash into a workpiece in a job a few days ago while setting up.

Ok, so after we fixed the wheels, and uninstalled, restarted the computer, and reinstalled 1.0.0… everything seems to be working now… :::whew:::

@saskia Stewart: Are you still having that problem?

@chapklc Glad to hear it, Kari. :grinning:

@gwilki Problem I flagged is in gSender version 1.0.0. Works fine if you start at z=0, but beware if Z > 0 and you click on goto X=0. I keep checking gitHub for a newer version

@saskia I just duplicated your problem, Stewart. In console, it showed that when I clicked on go to X0, gSender issued both a G0X0 command and a G0Z0 command. It does the same thing when you have Y at something other than 0, then click on go to Y0. It issues a G0y0 command and a G0Z0 command. I’ll ping Sienci tech right now.

I do NOT see the same. Does it happen every time?

I can’t reproduce this either. Tried after using probe xyz and setting xyz zero without probe.

Gsender version 1.0.0
Longboard Rev 1.4.3 8/26/2020
Windows 10 build 19043