gSender 6.6 Beta Windows - Longmill hangs with gSender after short time use

I have been experiencing this problem since the beta started, I have been struggling to reproduce it.

but Its happening more and more, so I am going to report it.

I DO NOT believe this is a gSender 6.6 issue, it could be anything. including a hardware fault.

  • Tonight I surfaced 3 boards of 12" x 12" on both sides.

  • all three boards were surfaced within 1 minute of each other as they were identical in size,

1 - ALL USB devices “Allow the computer to turn off this device to turn off power” is set to UNCHECKED

2 - using Surfacing gadget.
350 length, 360 width, bit diameter 60, step over 70%, Feedrate 3000
(everything else is set to default)

3 - clicked Generate Code

4 - Clicked on Run in main visualizer

5 - mount first board in quick disconnect clamp. (setting X ,Y, Z)
6 - Click Start Allow program to run (maybe a 1 minute execution time)
7 - unmount the board, and flip over and surface the second side.

Complete steps 5,6 and 7 3 times.

8 - move the head as far way as possible for Safety.

in my case, after completion of the 3rd board, the keyboard and pendant controls on the UI became un-responsive.

9 - I Closed the gSender UI
10 - Launced a new fresh copy of gSender

11 - click on the Connect to Machine, and selected the active come port.

12 - I was able to click on the Arrows, however they only moved every 20 seconds or so (as seen in the video)

all of the above steps were executed consecutively, with no longer then 30 seconds between each steps.

these are the most repeatable steps I have been able to execise.

Note in the video

Upper left of the screen is a green Check box and beside it, it says Connected.
Upper right side of the screen says Disconnected.

  • Around 16 seconds into the video, you can see me clicking on the keyboard. and no response from the head.

  • around 41 seconds the head moves a tiny little bit.

I can exit the client, and restart it, and nothing happens.
If however, I reboot the machine and re-try everything works again.

video:

1 Like

I wanted to update my post.

I surfaced another 8 12 x 12 boards yesterday, and sadly It didn’t hang as it did in the past.

so technically, my steps to reproduce the problem aren’t any good.

This still doesn’t change the fact this is occurring, I have seen 1 or 2 posts on the Facebook thread that people are experiencing the same behavior.

I myself have seen it a number of times, but only recently just reported it.

the problem is very obvious,

1 - the upper left USB connection shows that the device is connected.
2 - the upper Right “current state” shows disconnected.
3 - Issues to the Jog controls take seconds to be processed

it would seem that the device is in a conflicted state.

I too tried surfacing and the machine stopped responding. Switched to ugs and did 4 surfacing jobs 18 x 18 inches and no problems

@Menglor I’ll attempt to reproduce what you’re seeing, thanks for writing your process. I’ve seen perhaps two other mentions of this issue and I think I’ll need to distinguish if it’s a surfacing only issue or perhaps coming from elsewhere in gSender.

If you or @Dudley4166 find anything else in the meantime, the additional info would be useful

I don’t believe it to be a surfacing issue.

I think it has more to do with the start and stop of short programs many times over

So gSender hung a few times today, not sure why,

One time it was seconds from finishing and it just dug into my work and ruined an inlay.

I had to disconnect the usb restart the job.

There is 8 gcode jobs to get this far, I am happy enough with the work, but it was frustrating


1 Like

@Menglor I was curious if you’re still seeing this same problem in the newest version of gSender?

I have not seen this behavior in a while,

I have noted, there are a few people on Facebook casually mentioning lockup or runaway.

I have opted to tell them to come here and report it.

1 Like

Thanks for letting me know Stephen. Yes I’ve noticed some odd cases in the FB group that I’m hoping either the update will be solving, if not it’ll give us a better idea of where the problem could be coming from