gSender connection - PC issue

I realize this is probably a PC issue and not a gSender one, but have to start somewhere.

Just got my MK2 hooked up and it does connect to my newer laptop running windows 10 and I can jog to my hearts desire. But my older HP laptop, running windows 7, doesn’t connect or find a device. I’ve tried various start up attempts: usb plugged in 1st, with PC up and again with PC off, then power up control board via emergency power button, power everything up 1st, then connect USB, etc. but no fix.

I did try researching via forum, and noticed another post mentioned the MK “hums” when unplugging USB, stops when plugged back in, mine does this as well.

Appreciate any thoughts, since it’s been a minute since I did any deep dives into windows, Bios & com port issues.

Welcome to the Forum Ken!

You may need to install the driver by using the Arduino IDE software - see link below from the Sienci Resource Page. Also, not sure if you would need the 32bit or 64bit version of gSender as well, depending on your Windows 7 version.

Note: Sometimes it can take a moment for your computer to automatically install the drivers for the box if they’re needed. If you try to connect your machine but you cannot, you may need to manually install the drivers. You can do this by installing the Arduino IDE or you can follow the instructions on doing them manually for Windows.

1 Like

Thanks, Steven! You pushed me in the right direction, but I’m still not there, yet.

I installed the Arduino, but my version of Windows 7, Home Premium, has digital driver signature requirements and wouldn’t install the correct driver(s). This version also doesn’t have gpedit.msc, so I couldn’t find an easy way to disable the requirement. I stumbled upon a temporary way to disable via safe mode (F8 during boot).

I reinstalled Arduino, and I didn’t get the “couldn’t load drivers” message. This time I did get gsender to at least acknowledge it saw COM3, but still wouldn’t connect. Went back to the PC settings and changed the baud rate of COM3 to 115200 to match gsender, but still no luck.

This is all because I am setting up my new MK2, so instead of staying frustrated with PC stuff, I took a break and finished getting it working on the windows 10 laptop just so I could carve something. And I did! Mines a real song bird, sounded like a techno jam. Really do want to get it working with the other PC, though, so I’ll keep at it.

Thanks again. The friendly helpfulness of this community was a large factor in my choosing the Longmill.

@DaWoodster Not sure what else could be going on with Windows 7, but someone else may have a clue. You can always send a help request to Sienci and someone there can help.

Glad it is working for you on Windows 10 at least for now so you can have some fun!

The stepper motors do sing quite a bit on both Longmill versions and for grins and giggles if you google CNC music, you can find G-Code that will play different songs.

Steve

Steven, I put way more time than I should have in this, including playing around a lot with Arduino stuff. I did get Arduino to finally see com3, but never have been able to get gsender to connect to it.

I’ll reach out to Siecne direct and look up those CNC tunes, sound’ like fun!

Thanks, again

1 Like

@DaWoodster Ken: @stevendq (Steve) has certainly led you in the right direction. I would add only one other diagnostic you can run. In Arduino IDE, open serial monitor, make sure that it is set to 115200, and see if it talks to the Uno in your controller. You should see the grbl help line in serial monitor. If you see garbage, you will know that the issue is not with gSender. If you see readable text, it will be one more aspect you can tell Sienci tech.

2 Likes