Gsender not connecting to my machine

Hey there so i went to cut something today and hooked the machine upto my laptop opened up gsender and its not finding my machine i unplug the usb and the machine hums then stops when i plug it back in so its recognizing the connection but gsender isnt picking up my machine not sure whats happening iv tried uninstalling and reinstalling gsender same issue thanks for any help

Windows com port is my best guess but need more info

I plug in my usb but i get no connection chime i dont really know what other info to give im new to this stuff iv only been using the machine since november i havent changed any setting or anything like that machine connected and cut fine a couple days ago but wont connect now im at a loss right now no idea what to try

I even tried my old laptop that i started it with and it wouldnt connect to that one either also tried different cables

I don’t change too many settings either but updates in operating software chap my ass.
Lets try this:
SHUT DOWN everything including laptop in a normal manner
Make sure usb is plugged in to laptop (don’t plug and un-plug)
Turn on longmill power switch
Fire up laptop
Wait for windows to update or whatever and get some coffee
fire up gsender
see if there is a com port you can connect to
If there is not a com port to connect to, it is a windows issue, maybe windows 7?
Keep us posted

Ok when i get back home ill give that a try i am currently running windows 11 on this computer and windows 10 on the old one but i will def give this a try when i get back home will post what happens appreciate it

Try the old one with win 10 first

1 Like

No dice on that option for either this is extremely frustrating

@Brats13 When it ran fine a few days ago, was it on the win 10 machine or the win 11?

Is gSender set to run at 115200 baud, along with that same baud rate set for the com port that it is connected to?

If yes to this, try a different usb cable.

The windows 11 i found the cable that came with the machine and tried that but still nothing just seems odd that its not working on either computer could my connection in control box be messed up?

@Brats13 What version controller do you have? Do you have the remote stop button? Can you see that the leds for all 4 drivers are lighted?

Well i may have just effed myself more i opened the casing to see if anything was loose or burnt looking but didnt see anything put it back together and now i cant get any power im beyond irritaded now may as well just buy a new controler box now

@Brats13 I doubt that you need to buy another controller, Shaun. If there was no power to it when you took it apart, it’s pretty much impossible to have done anything permanent. I assume that you have unplugged everything from the controller - motor plugs, probe plug, anything else you have plugged in. If so, FWIW, here is what I suggest

1.Open the case again.

  1. Make sure that the Uno is firmly seated on the long board. It is just held in by the pins on the Uno.

  2. With the innards still out of the case, plug in the power brick. Don’t worry about the usb cable at this point.

  3. With the power brick plugged in, and the power switch on, confirm that the lights on all four motor drivers are lighted.

  4. If they are not, unplug the power brick and bridge the two terminals on the underside of the power switch. On early models of the controller, the power switch has been known to malfunction. Now, plug the power back in and confirm that the leds on the driver boards are lighted.

Post your results.

Im only getting the D9 light come on now

Im an idiot lol yeah the 4 lights on the back are on

I took the uno off and put it back on there was a button on the back side not sure what its for but i pressed it kimda hoping its maybe a reset

Still not connecting to the computer may have to order a new uno board

I have this but i dont know how to do further instalations i update the drive and it says its already up to date

@Brats13 Show me “port settings”.

Also, in device manager, right click on the com port that the arduino is attached to and select “uninstall device”. Then with the usb cable plugged in, restart the pc. Windows will re-install the drivers.

There is a more complicated method to actually install the uno drivers from arduino, but I have pcs working with the uno without them, so I know it is not required all the time.

Ok im out for the night ill give this a go in the morning i appreciate all the help guys very much appreciated