gSender Release 1.2.0 - file loading issues

Hi gang. Downloaded 1.2.0 last night and ran across some issues. I run Windows 10, latest updates, on an I7 pc with 16gb memory with an SSD drive. First it still takes about 30 seconds to load initially which is not bad to me. Second is the real issue. I start gSender and connect fine. I try to load a project and nothing happens. I can get it to load a project by disconnecting but when I try to reconnect it just spins the circle and won’t connect. I have to shut it down to get out of the reconnect loop. Not sure if anyone else is having this issue. Let me know what info I need to send you to help correct this issue. TIA

1 Like

I was having the same issue and I went to settings and restore default gender setting and then reload my settings, It started to work right after that. ( Make sure you copy your current settings before the restore)

@fafesb - Thanks Steve. I will give that a try. Will post results shortly.

That didn’t work. Started gSender. Exported current settings. Restored defaults and applied settings. Restarted gSender. Connected to test arduino not connected to CNC. Tried using default settings - no go.
Imported original settings - no go. This is on my design pc but use arduino for some testing. gSender downloaded from GitHub. Forgot to mention pc is X64 bit and downloaded 64 bit version. Thanks for your workaround Steve but it didn’t solve my issue.

2 Likes

@Heyward43 I just uninstalled gS 1.1.7 and installed 1.2.0. It has been my standard practice to uninstall the installed version before installing the update. All the settings. macro and shortcuts transfer, so it’s a safe process.

I can’t duplicate your problem, Heyward. I loaded and ran 4 files on my test Uno and they all loaded and ran. Like you, I am running an up to date Windows 10 64 bit machine. I have 8Gb of ram.

One thing that I did find, and I will do more tests before making this an “official” bug report, is that when I click either pause job or stop job, the job keeps running for a few seconds. That did not happen in 1.1.7 or in Edge 1.2.5. I’ll try some more files before making a bug report. I will not install 1.2.0 on my live machine if this is the case.

@gwilki - Thanks for the info Grant. I will give that a try. I usually uninstall the previous version but for some reason I didn’t this time. It was kind of late and was tired so forgot to do that. I’ll go ahead and uninstall both versions and reinstall 1.2.0. I’ll test and update shortly.

1 Like

@Heyward43 I don’t know if it really makes any difference by uninstalling the previous version, H. I just figure that it can’t hurt. :grinning: That said, if I lost all my “customizations” each time, I wouldn’t do it.

@fafesb @gwilki - Ok guys. I uninstalled 1.2.0 ok and tried to uninstall 1.1.7. 1.1.7 said it was missing so apparently 1.2.0 wiped it out, that’s ok. I reinstalled 1.2.0 but same issues, no project loads and hung connecting. I uninstalled 1.2.0 again and then went searching for any “leftover files” and didn’t find anything. I then rebooted my pc, reinstalled 1.2.0 and now all is working. Don’t know how but it works. Thanks for y’alls help as usual. I’ll mark it solved but don’t have an explanation as to how. Happy cutting.

@Heyward43 I’m really glad that you got things working, H. I’ll play some more tomorrow and report on my findings. I’ll be interested to see if you find the same issues that I have found so far.

Looks like I spoke too soon. Was working on some other pc stuff and decided to read some post on the forum. @gwilki posted a potential issue out and I thought I would see if I could duplicate. I started up gSender and connected. I hit the load file icon and selected a previous project. Guess what? Nothing happened. Looks like my problem is back or never really went away. No idea what to do now. Anybody else experienced this issue?

I too am having the same issue with 1.2.0. I installed the new release in the same way (w/o uninstalling 1.1.7). I’ll try these ideas too. I’m working on an older Win 10 laptop with the latest updates installed. I’ll report back. I did get it to load one time by going into the settings and ‘poking around’ and then tried reloading the file.

Also when it did load, the outline function didn’t work, but it would run the job. I’ll try to figure out one issue at a time.

@Heyward43 @nearingc This is just a shot in the dark, but it can’t hurt.

I was just looking through some old posts by Kevin on how to completely uninstall gSender. Some got off topic and dealt with an issue where previous versions of gSender would not load files to be run. The issue was tracked down to the PC not having an internet connection. I don’t have two clues as to why this would affect file loading, nor whether it has any relevance at all to the current problem you guys are experiencing, but when this problem arises, are you connected to the internet?

@gwilki @nearingc - I do have a good internet connection. Sometimes a little slow but active. I did see that server message flash by once but didn’t seem to make any difference. I even tried reflashing my Uno this morning to no avail. Just to add info I can connect and disconnect back and forth as long as I don’t try to load a file. Once I disconnect and file loads correctly I can’t reconnect.

@Heyward43 I’m going to bite the bullet this afternoon and uninstall 1.1 7 on my live machine and install 1.2.0. I’m doing a full backup of the shop PC now so that if things go haywire, I can restore to where I am now. I’ll report back later today.

1 Like

Thanks Grant. That was going to be my next step too. I’ll go ahead and get my backup done and wait for your test run results.

@Heyward43 Well, H, I’m not going to be of any help on this one. I uninstalled 1.1.7 on the PC in my shop. I installed 1.2.0. I was able to open gS, connect to the LM and load and run in air 6 files.

So, in short, I can’t duplicate your problem. Sorry.

I have found a couple of things. The visualizer is inferior to the one in Edge 1.2.5. Also, when I hit pause or stop, the machine stops right away. The visualizer continues for a few seconds. Not a big deal, but weird.

Good luck, H. With luck, the new reporting function in 1.2.0 will tell the guys at Sienci what is going wrong.

Thanks Grant. Looking at facebook looks like a lot of others are having the same issue. One person has a video that perfectly shows how mine is doing. I haven’t tried my cnc pc yet but will do so shortly. I definirely think the Sienci gurus need to address this one. I’m going to remove 1.2.0 on my test/design pc and reinstall 1.1.7. But it seems some are having issues backtracking. We will see.

1 Like

Hello forums!

I have a Macbook Pro 2015, and for the last ~7 months, Ive been running gsender v1.1.1 and then v1.1.7. I have had no issues with the software until today.

Today I saw there was an update to v1.2.0, and I got excited so I downloaded and installed it.

I had my laptop out in the workshop near my longmill, so I connected to the cnc and tested out the controls - it was jogging like a champ!

I then tried to load one of the .nc files I have been carving for the last ~3 months (Ive run this file roughly 50 times already)… and literally nothing happened. The file simply did not load.

I then looked on the forums, and I saw that one user had a similar question and needed to update their MacOS… so I updated to Monterey 12.6.6

I was inside when I updated to Monterey, so then I tried loading a file… which was successful! So I took my laptop back to the machine and the machine would not connect. I can see the machine as an option to connect to… however when I clicked to connect, it just kept showing the spinning loading icon (for over a minute until I stopped it).

I was able to differentiate that I can either connect to my machine -or- load a file. I currently cannot do both.

I also tried (several times each) to re-install the previous version gsender 1.1.1 and 1.1.7… and neither programs will even open at this point. Both previous versions just render the initial loading screen for the gsender software and then do not open. Ive waited 5+ minutes for both versions.

Any help here would be appreciated - Im literally unable to operate my machine and Im trying to fill an order for a customer.

Thank you!

Here is a video of my current situation: gender 1.2.0 will not load file - YouTube

1 Like

I experienced same issue today using a windows laptop.