Has any experienced random reversing of an axis?

Has anyone ever had an axis reverse direction out of the blue? I have been using my Longmill for over a year with relatively few issues. recently in the middle of a project, the machine just started to go off in the opposite direction on the X axis. Initially I assumed that it was an error in the gcode file, but I soon discovered that when jogging the machine manually it did the same thing. I tried reversing the direction on the software and it worked, briefly before seemingly randomly reversing again. I switched it back and the same thing happened. Sometimes it would go in the proper direction, but jogging again it would reverse on its own. I am assuming it is something I have done (or not done), but am baffled as I have been using it for months merely loading toolpaths and running them without messing with any settings. I have been using Vectric Pro and have had consistent results with the only screw-ups being my own doing.
Something else that also started occurring at the same time, is the X axis just grinds away in precise movement setting (on gSender) as if it has run into a hard stop, but on Normal and Rapid, it moves just fine.

I am truly at a loss at this point. Had to step away. If anyone has experienced anything like this and knows that cause, or better, the solution, I would extremely grateful for the help…T

@Torminater , I would start by checking the cabling from the controller to the X-axis stepper motor. Unplug and re-plug the cable on each end. Check for loose or broken wires in the cable.

Thanks Paul. Unfortunately I have checked and double checked the wiring.

@Torminater Torrey: For your second issue, what size are the movements in precise? Have you tried increasing both step size and speed?

For the first issue, I have no clue. :grinning: Have you changed anything since it worked well? For example, added dust collection, re-routed cables, etc? It may be worth re-flashing the firmware on the controller. Use gSender to do it. It’s much, much easier than using the arduino ide.

Thanks Grant,

That’s the frustrating part. I have changed nothing and added nothing. Just seemingly out of the blue. The settings are the default from gSender. I am not at my machine now so I can’t say what the values are. I just know it worked fine on the default settings until this happened.

@Torminater Well, then, clearly, it’s haunted and you need to call an exorcist. :grinning: If I were you, I would try a firmware re-flash.

Ya. That is what I was thinking. Just going to have to figure out how to do that. I think I will uninstall and reinstall all the software too. Thanks again.

@Torminater In gsender, there is a button to flash the firmware. They have made it a very easy process.

Perfect. I saw that, but was convinced it couldn’t be that simple. But simple is good!

Thanks once again!

@Torminater Post back when you’ve done it, Torrey.

I had this happen on one side of my Y-axis. The connector had come slightly loose on the side that was acting up. I re-seated the connector at the stepper motor and the issue went away. It might not solve your problem but that’s what worked for me. It was pretty wild to move the Y axis and suddenly have one side reverse direction. No harm done and an easy fix in my case.

@Slikker Thank you for your input. I have checked and re-checked all my motor connections already. But may I will get out my multimeter and check the continuity of the cables. If a bad connection caused similar behaviour in yours, there is a good chance it is a similar issue.
Thanks again…T

@Torminater Torrey: Reading Ron’s post has me thinking about cabling. I had not thought of that before. You may want to check all the set screws in the green motor wire connectors. In doing so, check to see if the wire ends are tinned. If they are, cut off the tinned end before tightening everything up.

I found the cause(see photos). I am not sure how i missed this when checking the cabling. However, I am not sure if this is the cause, or the result of a larger problem. A poor connection can cause arcing and/or excessive heating. I am wondering if you know of anyone having encountered this issue before and if it was merely the result of a bad connection, or if it was the result of excessive current or some other internal failure.

The next obvious questions are: where can I buy a new connector; and, will the pin in the controller be okay if I just clean it up? (Assuming it is merely the result of a poor connection)…

As always thank you for your input and assistance.


@Torminater . I think the connector probably comes with both male and female halves. If you can find one that matches the footprint of the one soldered to the controller board I’d say replace it. It could be hard, if not impossible, to clean the male connector to get it back to its original low resistance state. If you are desperate you could try.

That pin obviously over heated. It was either due to high current, or, as you suggested, a poor high resistance connection on that particular pin (A-). I tend to believe the latter because the same current flows through A- and A+ and that pin looks fine. If this is the case, then replacing both halves of the connector should resolve the issue.

Thanks Paul. That’s what I was thinking. Frustrating that Sienci doesn’t include the connectors in their spare parts available for purchase. I ordered some from Amazon but they are not expected to arrive until October. I will see if I can find some locally in Calgary. Do you know the actual type/name of the connector? I can recognize them to see them, but it would be easier to phone around and ask rather than drive all over the place to see if anyone carries them.

You are welcome. Found this about the connectors:

LongBoard Connectors - #4 by chrismakesstuff

It only lists the female half of the connector.

I did a little research and this might be the male half.

Ningbo Kangnex Elec | Ningbo Kangnex Elec WJ2EDGRC-5.08-4P | Pluggable System Terminal Block - LCSC.COM

It’s called a “header” and the female have is called a “plug” and the connector system is called a pluggable terminal block.

Just google 5.08 pluggable terminal block . Add “header” or “plug” depending on which half you want. I did find sets of both.

Thank you again! I am tempted to just hard wire it in with no plug, but I’ll see what I can find.

@Torminater Torrey: The Sienci techs read this forum and will likely reach out to you. I would suggest that you email them directly, too.

I must admit that I surprised that there is enough juice in the circuit to fry a pin like that. Shows my ignorance, I guess.

Edit. On my controller, there is an unused 4-pin plug that is available for limit switches. If you are not using it, and if you can clean up the terminal block, you can use it to get you up and running.

1 Like

Thanks Grant. I saw the limit switch block, but I do intend to install them when I find some of that ever illusive ‘free time’. I found a place in Calgary they had them in stock, so I plan to pick the parts up today.


1 Like