Has anyone tried using the remote control option in gSender with a mesh WiFi?

I recently upgraded my internet service to get better speed for streaming after i finally got rid of Comcast In the process I also upgraded WIFI coverage in my house by incorporating a MESH (Deco X20) WiFi system. My workshop and CNC are in my basement. My old Comcast router (& WiFi) was also in my basement workshop and I had successfully used the gSender (1.22) wireless remote option to control my CNC through my old iPhone 7. However, now I have a MESH router in my workshop that is wired directly (backhauled) to my new fiber optic router that is in a different room. Both my CNC computer that runs gSender and my iPhone are connected to the same MESH WiFi network but now I can’t access the computers gSender program from my iPhone. Has anyone had any success in using a MESh WiFi system in conjunction with the wireless gSender option, and if you have what are the tricks?
On a different but related note, has anyone managed to find a way to change the default metric settings to imperial (inches) on the wireless remote control option using smaller iPhones like my old iPhone 7. Even when I physically turn the phone to “landscape” I do not get access to the edit option in the gSender software and can’t scroll sideways. I worry about setting zero options for bits using metric settings on my phone and imperial settings on my CNC computer. If I can get the system to work in my MESH environment I’m still stuck not being able to synchronize settings between the computer and my iPhone 7.
Any help greatly appreciated!
Cheers, Tig

@Tig I have no answers, Don, but I have moved your question to the gSender topic. I believe that it will get more attention here.

I recently posted on this topic and got a solution.


Thanks CrookedWoodTex, am I right in thinking that we will have to wait for the next iteration of gSender to be able to toggle between units on smaller screen phones?

Thanks, I tried to post it there originally but couldn’t for some reason. I probably chose the wrong options.

1 Like

Well, that was promised. :smiley: I’ve been able to use my iPad with unfettered access to all settings.

I had thought about using my iPad but I need to sort out the issue with the MESH WiFi system before I do anything else. Hopefully, I can get that sorted out in time for the update :stuck_out_tongue:

Hi Tig,

I use an Asus mesh configurtion in my home and my workshop a good 40 meters down the street. it is backhauled via a D-lan that is directly connected into the main mesh node. This setup lets me use the remote g-sender option on my phone, tablet and television. Maybe try to backhaule directly into your main mesh node and see if that helps.

The problems you have with settings is on of the reasons I don’t use remote anymore and have gone back to walking the green mile when probing. If I use my android tablet with firefox I am juuust able to touch the probe button, but in firefox, I cannot enter the settings page to change to the auto probe.

When I use Chrome, I can access settings, but cannot reach the probe button. To add to the frustration, changing the settings on chrome doesn’t influence the firefox settings.

I also encoutered some hanging when togling the machine resulted in me having to use the oops button cause the machine kept running in the direction It got nudged in.The difference in settings between my pc and the tablet add an extra reason to not use the remote option anymore. It seems not mature enough to savely use.

So I went back to using my double bluetooth keyboard, plugged into the shop pc. With shortcuts, it is almost possible to work remotely at the machine.

Hi Eddie,

If i understand your configuration correctly you have your CNC computer directly backhauled to a D-lan switch? connected to the main MESH node. I am using a TP-link internet switch connected to the main x20 MESH node. I then backhaul from the switch to another x20 in my workshop and connect wirelessly to my CNC computer. Is your suggestion that I directly backhaul the PC to the switch and bypass the second MESH node? That should be easy enough to try, I will let you know how I get on.
As far as the remote goes, another user told me that the remote settings tab will be easier to access in an upcoming iteration of gSender.
Cheers, Tig

Hi Tig,

Not directly. I have my second node in the shop backhauled via a D-lan to the first node back home. The pc is wired via a simple swiths to, but that shouldn’t matter.

To have the nodes of your mesh to be able to give the same sid, it’s needed that they have a link together, being 5g wifi or hardwired. If you have a 5g link, it might be unstable and drop out of the mesh, leaving you with two seperate acces points.

As I understand it, this backhaul needs to be between the secundairy node and the main node, not to another router. If I understand correctly, you are backhauling to your main router?

This might be more clear to what I’m trying to say.

Yeah, I have attached a pic of my set up, its based on option 2

I am now wondering if I have maybe screwed up having a different network name to the nodes than the main router. I wanted to differentiation between the two, not sure why now I come to think of it.

Having the same ssid is the purpouse of having a mesh. But, come to think of it, it shouldn’t matter. As long as you are in the same ip range with both of your nodes, it should work. Maybe your old phone doesn’t work on 5g wifi and switches to 4G.

If you hardwire your pc to the second node and log the remote device on the same nodes wifi, are you able to work the machine?

I’ll get back to you on that early next week. I’m just getting ready for a craft show this w/e

Cheers, Tig

1 Like

This sounds like the defender firewall on your laptop may be blocking thebiotraffic from your phone.

Make sure the laptop sees the range as private in the network neighbourhood configuration and trusts other private connections.

When you start gsender with the remote option enabled do you get a Windows firewall configuration prompt?

Is the ipaddress that gsender is using for remote consistent with what you are expecting?

Ie if you use as your network.
Router is

Your PC would be assigned an IP address from the same subnet

Ensure that your deco mesh allow communications between wireless devices disable AP isolation mode.

It may be enabled by default it is a security configuration. Often referred to as peer to peer communications

See this reference. Good luck

1 Like

Hey JSB carver,

Welcome to this forum. Straight into helping people out ey. Nice tips 'n tricks.

Looking forward to your projects and the like. Guitar building is it? straigh into the deep. have you seen the sienci guitar building tutorial? Lots of stuff to take from that series.

@Spamming_Eddie I believe that you posted this under the wrong topic, Eddie. Yes??

I was welcoming JSBcarver, as requested by the first-post-note.
It is a bit off topic, so I’m split between a bit of a no and a bit yeah.

@Spamming_Eddie No worries, Eddie. It’s just tat JSBcarver does not mention in his post on network configuration that he is carving guitars. :grinning:


Thanks for the input. Definitely not a firewall issue, and the Decox20 has AP isolation turned off by default, so not that either probably. Given that I cant yet adjust the screen on my iPhone to set the metric/imperial units i have given up. I found an xbox controller with a bluetooth option and have it set up on my pc, while I can control the x/y axis i cant see how to control the z axis in gSender. Is there a setup in gSender settings where I have to designate the xbox controller as an input? The shortcuts for the xbox controller are all enabled but no z axis control that I can find. Do you happen to know how to get this option functioning, or anyone else on the forum?