Help! I don’t know what I’m doing

Help!!! After having my machine for months I have barely been able to finish assembling it… now that I have finished it what’s next?? How do I get the machine to move?? Sorry but I do not have any experience with the cnc

@Joe4remodels - Joe, now you need some software to design your project. This is done with CAD software. Once you have designed your project save it as a .svg or .dxf file. This file is then loaded into a CAM software program to generate the gcode toolpath. This gcode is what drives the LongMill and is run by a gcode sender. Go to the Sienci labs site and look at the build section and look at the Software section. Some examples of CAD/Cam are Easel, Carbide Create, Vcarve and Carveco Maker. Gcode senders UGS, CNCjs and several others. Take your time and look for youtube tutorials for beginners. They will walk you through work flow, setup and running your project. Take your time. It will come together before you know it.

4 Likes

Hi Joe. I was just like you when I got my CNC. While it is confusing at first, you need to invest some time in educating yourself. It is a pretty steep curve, so be patient. There are hundreds of YouTube videos that will help you with everything from concept to finish. Don’t be bashful. Reach out. Answers to all of your questions are out there. Good luck.

3 Likes

All good advice. I was exactly the same a few months ago, this forum is full of really helpful, friendly and extremely knowledgeable people. You’ll learn to love your mistakes and frustrations too!!!

3 Likes

Thank you everyone!! You all are very helpful and kind. Unfortunately I didn’t study up and I bought a Chromebook thinking I could use it with my longmill :upside_down_face:

Try Candle as your gcode sender, believe it will work from usb stick. Little chrome experience but think it will workonchrombook same as a window laptop. Good Luck

Hi , I am assembling mine now and am worried about facing what you are facing at the time of your post.
I have been doing nothing but research since before I ordered my 30 by 30 LMill
I am sure someone will correct me if I am wrong, so her I go…
CAD is used to design or modify (vector) Sketches
CAM is used to determine hoe to cut the sketches
INTERFACE is used to take the instructions from CAM and makes the CNCF do stuff.

The Interface program is most troubling to me. I can play with CAD ad CAM without a CNC machine but not so with the Interface program.

The most intuitive program I have found is ESTLCAM it does the CAM and Interface too.

good tutorials on website. and not too expensive

Though you’re correct that you can’t really fully test without having the total setup, you can usually simulate Gcode in various gcode senders. I personally recommend Fusion 360 for both CAD and CAM stages; from fusion you can generate .nc files that are suitable for sending to your long mill. Then, I would use CNCjs to send to the actual machine for a cut.

If there was interest, I could write up a post for first time users who want to try this workflow. Though Fusion seems overwhelming to some people at first, the advantage of this workflow is that you’ll be able to design everything and simulate in advance for high confidence, repeatable work.

4 Likes

My machine is built but so how do I get to do anything???
I tried configuring it with UGS and managed to jog the Z and have the X and Y growl at me but that is it. tried following the instructions on website and found …
https://sienci.com/dmx-longmill/grbl-firmware/

Followed these instructions as best I could and now the machine does nothing*.

Nothing being jogging X, Y, or Z using USG CNCjs and ESTLCAM
has is been a plug and play experience for others? is my situation the exception or the norm?

Help me quell the desire to take a bat to this thing.

before you thing I am just living up to my funny nickname, I have an electronics technologist diploma and a degree in Electrical Engineering. :face_with_monocle: :grin:

1 Like

@CluelessJoe Hang in there, Joe. There is/was no need to flash the arduino. It was done “in the factory”. Now that you have done it, there may be additional things that could be causing your problem.

I suggest that the first thing that you should do is to confirm that your arduino was flashed correctly. To do that, follow this instruction from the Sienci site:

" You can check if your firmware has been correctly installed by going to Tools > Serial Monitor. This will open a window to show the console output of the Arduino. If your output looks garbled, make sure to set your baud rate to 115200. As you can see, the output shows the firmware version and build date."

If you do that and you see your firmware version and date, the you have passed the first test. :grinning:

Next, as stated in the Sienci site, make sure that you close the arduino ide. If you do not, the gcode senders will not work.

If all is well so far, it’s time to set up a gcode sender. I am more familiar with UGS, so I’ll start with that one. You say that you had it working - sort of - so I don’t need to tell you where to get it.

The way that you described your initial problem would suggest that it was a simple matter of increasing the step size in X and Y in UGS. By default, I think it is something like 1mm per minute, so it appears that it is not moving at all and merely “growling”. So, if you’re still with me, and you are in UGS, set the step size for X and Y to 1000. Click X and Y to jog and see what happens.

I will try again. RE “…shows the firmware version and build date…”
Am I looking for GRBL 1.1 or something different?

I will update soon and thank you for your assistance.

on this subject I guess I really am clueless lol
I think I have a handle on CAD and CAM ( or I will soon enough) but everything about the interface is a foreign language to me

@CluelessJoe It’s a bit tough to see on the sienci page, but you should see

grbl 1.1h ($ for help)
LongMill build feb 2020

That’s as close as I can come. Take a look on the page where you got the flashing instructions and you will see the graphic.

Again, though. This did not need to be done. I’m assuming that you did it, so that’s why I am going the way that I am. Based on your comment that, on first build, UGS did some things, but after you flashed the firmware, it did nothing. If my understanding is incorrect, we should back up and you can clarify.

I think I cleared the EEPROM cuz it is blank after Tools > Serial Monitor
I tried to flash it several times but I must have failed although the process looked successful

RE step 3

3) Uploading the GRBL firmware

We’ll be opening the program that will flash the firmware to the LongMill. You can find the grblUpload.ino file at grbl > examples > grblUpload. Once you find it, open the file."

where do I find grblUpload.ino is this supposed to be the nested zip file off their site?

EDIT
it says to open it , but do you upload it too?

I finally Found it the file!
C:\Users…\GRBL-LongMill-Firmware-Feb-25-2020.zip\GRBL LongMill Firmware (Feb 25, 2020)\grbl.zip\grbl\examples\grblUpload

For any others having the same problem.
I spent a hour going through every inch of the dropdown menus looking for it.

the library file already exists. so it looks like I did that correctly last night

@CluelessJoe I did not even try this on my Mill controller. I did buy an arduino uno board so that I could simulate jobs, using my home office PC. I thought that I followed the instructions strictly and it still took me 3 tries to get it right. So, I do sympathize, Clueless.

I think I need to delete the grbl and re-add. the error messages lead me to think I did it wrong.

Arduino: 1.8.13 (Windows Store 1.8.42.0) (Windows 10), Board: “Arduino Uno”

In file included from C:\Users\Owner\Documents\Arduino\libraries\grbl/config.h:30:0,

             from C:\Users\Owner\AppData\Local\Temp\arduino_modified_sketch_319935\grblUpload.ino:1:

C:\Users\Owner\Documents\Arduino\libraries\grbl/grbl.h:68:4: error: #error “Required HOMING_CYCLE_0 not defined.”

#error “Required HOMING_CYCLE_0 not defined.”

^~~~~

C:\Users\Owner\Documents\Arduino\libraries\grbl/grbl.h:108:4: error: #error “WCO refresh must be greater than one.”

#error “WCO refresh must be greater than one.”

^~~~~

C:\Users\Owner\Documents\Arduino\libraries\grbl/grbl.h:111:4: error: #error “Override refresh must be greater than zero.”

#error “Override refresh must be greater than zero.”

^~~~~

exit status 1

Error compiling for board Arduino Uno.

This report would have more information with
“Show verbose output during compilation”
option enabled in File -> Preferences.

@CluelessJoe I’m more than a little lost CJ. All l can say is to make sure you do every step in the Sienci instructions. No offence. The big one, I think, in you case, is this one:

You will need to make sure to delete any old libraries for GRBL. Arduino typically saves libraries in the Documents > Arduino > Library folder of your computer for both Windows and Mac. If you do not delete the old library first, you will install the old version of GRBL.

As I say, it took me a couple of times to get this right as I found it somewhat weird. Others here have done this, though, so maybe they will chime in with advice.

Success I can jog xy and z!

once I re added the library I uploaded it from the same window opened by grblUpload.ino

NOTE to all newbies When you adjust the wheels on the rails (in the winter) remember there is a lot of thermal expansion. after having the heater on for a while the wheel were so tight the motors were spinning in the couplers

4 Likes