Inadequate documentation for the "Start from line #" functionality

I am having a terrible time trying to run a job on my Longmill MK 2 48 x 30 CNC using gSender. The job keeps stopping after running for a long time. I have all the power settings turned off (in Windows Control Panel), including the USB port. The job got about 21,000 lines into the cut (the project is a topographical map), and the router just stops moving (still on and spinning, just not moving). I tried to use the “Start from line #” feature, but the documentation on how to use that feature is not very good.

The message I received from gSender when the job stopped said that the last line # was 21,782, but it’s not clear exactly what I should do with that info. I don’t know if I am supposed to manually raise the bit out of the material, then go to XYZ zero (original zero for the project), or if I’m supposed to leave the router and bit where it stopped, and just hit the Start from line #, type in 21,782, and then it should resume properly.

So, I tried just typing in 21,782, and the router lifted up, moved ahead in the project, and then dropped into my material, and started cutting in an area where it should not have been cutting, destroying my project (which had been running for about 4 hours).

Does anyone have any actually useful instructions on how to use this Start from line # function that explains exactly how to use it and what to expect? (I still have to figure out why the work stoppage is happening, but it would be good to know if you can ACTUALLY recover a jot if it does stop. The Sienci write up on this function makes it all seem so simple …)

Thank you!

when you used the start from line feature was your XYZ still zeroed out for the project?

If I need to use it in a situation where I lose XYZ zeros like when I turn everything off and continue the next day, I reset XYZ zeros and then key in the line it stopped on and hit start. I don’t position the router anywhere except for X0 Y0 Z0.

If I use it and the XYZ 0’s are still correct then I raise the router clear of the workpiece, mainly because I don’t like starting the router while it is sitting on or in the workpiece. Then key in the line I want it to start from and click start.

In both cases, I keep my mouse on the pause button ready to click as I watch where the router is about to engage with the project.

I’m not going to be much help In why it stopped, but we might want to figure that out. Was there an Error message in gSender?


When you typed in the line number did you move the router back to its X0 Y0 Z0? Or leave the router where it stopped? Losing the zero points might explain why it cut into the wrong area.


I tried two different methods. First I restarted it from where it stopped. It dug into a place it should not have. Then I went to xyz zero and it cut in a different wrong place. Both times it was beyond where it stopped.

Do you have the inductive sensors and homing enabled? I’m thinking without those, there is no real way to know where to restart the job from. The basics about restarting a job from a specific line are linked below. I know I’ve stopped a job and corrected something (or went to sleep) and was able to reset and restart from maybe 50 lines back and couldn’t tell where the job stopped:

@SteveCool I’ve only used the feature once, but it worked as advertised. I do not have inductive sensors. In my case, whatever caused the stop also caused the LM to lose zeroes. Since I had used the touch plate to set them, I used it again to reset them. Then, I entered a line number some lines back from the last line that gSender said was run. It worked fine. I accept that YMMV, but as I understand the documentation, the process that I followed is the one that is foreseen by Sienci.

Just to be sure, you moved back to you XYZ zero point, then started from a line number less than the line number recommended by the software?

1 Like

When you say you couldn’t tell where the job stopped, does that mean that it successfully restarted at the right place and carved correctly?

I’m not sure if this question is addressed to me. In my case, the freeze caused the LM to lose its zero position. I found that out by returning to xy0 and saw that it was in the wrong location. So, I reset all zeroes using the touchplate. Then, I used the start from line feature. As set out in the gSender docs, I went back a dozen lines or so and started from there.

Great. Thank you so much! I’ll give it a go.

1 Like

As I believe that this is a much misunderstood feature, please post back with your results.

Here is a link to another method to resume a 3D carving that has stopped/failed from some reason. The link is specifically for users of Vectric software, but it may give some ideas that can be used in other software, too.


On the Start Job there are 3 little lines in the upper right corner. Click on them and it allows you to start on any line. I usually go back 50 lines.