Incorrect Movement Destroying Workpiece

Cnc newby-using Longmill with Vcarve Pro V12 and gSender. The machine will be working normally and part way into the project will suddenly plunge into the workpiece, destroying the project.
It sometimes goes all the way through into the wasteboard and jams the router.

Oh dear, that sounds quite bad. Is there any pattern to how it happens? Can you attach the gcode you were running?

No pattern whatsoever. I am working on a two sided spoon with four files. I have made it all the way to the last file before it goes bad, but sometimes fails on first. Also regenerate the gcode every time.
I am going to try reinstalling gSender. Can’t attach file because I am a new user.

I’m new too and experiencing the similar problem with my Z movement. I have had one successful run of 21 seconds, cutting .05 deep, in a small rectangle. My second run is when I had the Z plunging problem. Mine plunges in right away. I ran the calibrate and the system thinks it moved downward 30mm. The actual movement was 60mm. I try and run a program with a very simple profile cut. I tried at first to cut through a plywood .71. The bit went all the way down through the material, spoil board and table top. I’m stuck at this point. Longmill MK2, VCARVE PRO V11.5, gSender 1.4.7

I have installed UGS and so far have not had any problems. There is a bit of a learning curve for setup.
Will let you know in a couple of days how it goes.

Update: Sienci support helped with the plunging problem. Somehow the setting $102 is supposed to be 200, mine was $102=400. I went to Firmware Tool and selected restore defaults. The value was changed back to
$102=200. I have no idea how it was changed in the first place. That fixed that problem.

1 Like

ArizonaWayne, glad you got your problem solved! Mine however is no better using UGS.
I destroyed two more spoons when making the finish cut. The last one, the machine suddenly gouged out the end of the spoon and plunged through into the wasteboard. When I returned to the XY zero point, the coordinates were way off. It never happens in the same place.
I am attaching a couple of images.


@knnewell What post processor are you using in VCarve, Ken?

Grbl(inch)(*.gcode)-also tried the metric version.

1 Like

@knnewell How thick is the material? Could it be that you are hitting the top of the Z travel at some point in the project?

The material is 1.25 in and the safe Z is 1 in above material. It never hits the top-I am watching it the whole time.

When it crashes and the xy home changes… do both x and y change? Is it only the x or y that is off? Or are both x and y off after the crash?

It is both and possibly the Z, but didn’t check but since the router gouged the workpiece and plunged through into the wasteboard, I’m assuming the Z was off also.
It’s different every time.

I think I figured it out. My feed was set too fast-120 inches per minute and I found a loose roller on the gantry. I adjusted it so I could barely turn it by hand.
I ran the spoon project with no problems.
I suspect it was missing steps and throwing all the coordinates off.

@knnewell Since this issue is resolved, I am closing the topic.