Jogging with gamepad

I don’t have a gamepad yet, but wondering if when you jog with one, does the speed/distance correlate to the selection on Rapid, Normal, and Precise modes or will you jog as long as you hold the gamepad button and stop immediatly when released (as opposed to selected mode steps)? Tks


I have Logitech F710 Wireless, but tend to use my cell phone with the remote option in Gsender. You can set up your game pad with key short cuts for rapid and precise. My laptop is old so it tends to lag between what I press and how quick the machine reacts. With the remote option I do not get the lag.

1 Like

Welcome to the forum @Jarose ! Excellent folks with sound advice. Make yourself at home and enjoy your stay with us!

I realize I can set short cuts for rapid-normal-precise. To clarify, can one use the joystick to jog based on time the joystick is held over rather the the pre-determined distance increments? Wondering if that functionality exists. Thanks for responses. Also, thinking maybe I posted this in wrong forum section. Sorry about that.

Would like to add how much I prefer the Gsender software over all the others I have tried. Great stuff. Hats off to the developers!

New Edit: Found answer. Just found an article here on Edge 1.3.6 and they implementing that feature now. I hope the functionality is somehow added for other external components. Not using a gamepad, but building a control interface (arduino Leonardo based as keyboard) using the shortcuts already available. Would rather the tactile buttons than the touchpad on laptop or touch screen. Regular mouse is pain for dust. Would love to add a joystick that starts slow and speeds up as it’s held longer for longer jogs. Need a set of shortcuts to change the rapid-normal-precise speeds without changing the jog distance. And push/hold to jog shortcuts, if thats possible.

1 Like

@Jarose I just use a wireless mouse. I have an old monitor mounted on the wall and just use it to access every gSender function, so simple but works great.

Mouse not so good for me. Too many crashes trying to grab the mouse and click in the screen before uh oh. Have a keypad designed and working, and have jog buttons on it like gSender, but thinking a joystick would be easier to use. Experimenting with the joystick function tonight just using a couple potentiometers on the arduino, calling macro functions. A bit clunky yet, but working in principle. Have set up so the harder I push the joystick left,right,top,bottom the faster the jog goes. As I ease off, the jog slows. However, there are bugs to be worked out yet. Was hoping this was already built into gSender when I posted. Thanks

1 Like

@Jarose sounds like a plan, glad you’re getting what you prefer.

I also have thought that is how the joysticks should work. Like with an XBox or similar controller with two sticks that the left stick should control the X and Y and the right stick for Z with proportional speed. Sadly this is not built into gSender yet.

I have gone so far as to start making my own toy G-Code sender to implement that functionality but it’s a long way from done. So it’s interesting to me that you have found a work around. Good luck in getting this working!

Thanks. Its not really working well because of the grbl command buffer and the stop jog (ie ‘)’ \x85) interrupt is not working to purge backed up commands. So, I downloaded Edge version, thinking I would set up a joystick on same Leonardo. As a test, I am trying to get my wingman yoke working for the X Y axis to see how it works, but it is reconized by edge and the hardware tester fine, but no action to machine, buttons or axis. Was hoping the rate of acceleration would be built in there :frowning:

I’m not sure why that doesn’t work. According to the wiki 0x85 should cancel queued motions. Not sure if you know about that page or if it’s applicable to the way you are trying to do this but thought I would share just in case.

Yes, I am fully aware of how it is supposed to work. I feel as I am forging ahead of the developers. Think I will hang behind the cart for a while as they get their end smoothed out. Using EDGE I built an arduino base joystick and got it working but it is very choppy and does not seem to be variable, about the same as my earlier attemps using macros. Operated like buttons held, which I already have implemented in by pendant build. BUT gladly the developers are working on us being able to configure our custom gamepads. What I would LIKE to see (and I know I am a strange bird who likes to do most things my way) is a variable or stepped speed joys with the first push a precise/slow movement, then like a 1/2 second delay and variable increase from there. That would allow one to zero in on a target, and when close, just tapping the joys to get you bang on. May be a tall order with grbl because of the commands. Going to order a decent joystick and incorp it into my build anyway and leave issue this for a later date. Love the software so this is not to be perceived as a bug or criticism. I will take what I can get lol.

1 Like

Setting rapid or normal sets the max speed for the game controller as it does for the gSender jog controls; however speed increases gradually as you move to full deflection which doesn’t happen with the Jog controls.
I use an Xbox controller that came with my Onefinity machine, and fell in love with it’s use. About the only thing I liked about the buildbotics controller.
So, I switched back to Scienci’s Longboard with gSender Edge 1.3.10 that has better implementation of Joystick control setup. However I’m still having trouble getting it to work properly. Could be I haven’t figured it out yet as you’re dealing with or it’s the implementation on the Longboard. I have ordered the SLB and am hoping that it will improve the Joystick use.
I haven’t tried the Logitech F710 gamepad yet, though I suspect that they will need to make it a direct connection to the controller for any gamepad to work properly.
Like you, I really like Scienci because of their great support; they respond and help with questions and problems very quickly.

@Bruces-CNC @Jarose @Parrott @_Michael
I’ve moved this topic to the gSender question category so that the gSender team at Sienci is mor likely to see it.

1 Like

Thanks Bruce. Though I said I would let it rest, today I re-configured my arduino with xInput to emulate an xbox controller and it works like you said -variable speed. Good. Ordered parts to incorp 2 joys in my build, but not sure if I want a Z axis one yet. Still found the movement sometimes a little bumpy, but when I get the actual joysticks (just testing with a couple pots now) I may be able to tidy up my coding a bit. I think it’s all going to work out in the end the way I want it. And to the moderator, I kinda figured I had post in the wrong place. Had the software for over a year now and never had any troubles, so didn’t know this forum was here until last week!

1 Like

@Jarose I’m glad that you found us. As you have seen, it’s an excellent source of help and information. :grinning:

1 Like

@Jarose The following quote is from the new gSender 1.4 release notes.

Joysticks are now able to jog the machine along any axis with variable speeds based on how far you’re moving the joystick.

I thought you might find that interesting!

1 Like

This seems to be broken on OSX even in 1.4.1. while the shortcuts pane shows interaction with my Logitech gamepad, showing ‘x’ flashing when I press right, there is no jogging of the machine through the controller. Mouse clicks on the UI work fine. I’m reverting to 1.2.2 which worked fine with my setup, so I suspect this is a regression. Intel Mac, osx 12.7.4.

I only tried one button on gamepad and it worked ok. Used gS 1.3.1 (windows 10). In meantine, I don’t plan on using many, if any, buttons as I have a keyboard emulater set up with the commands.

I’m also having problems with 1.4.1. Jogging with the F710 is very jerky, while still very smooth when using the keyboard. Not sure what to do at this point, I would prefer not having to revert back to a previous release.

I also found the joystick jogging very inconsistant/jumpy, but I figured it was my rudamentary coding. I experianced the same thing, only much worse, when I wrote my own code using GRBL jog commands in macros. It’s a beta release, so I am hoping they are still working out issues. Don’t suppose its so easy to get smooth movement of varying speed using GRBL because of command buffering, timing, etc. I don’t think (could be wrong) that kind of movement is part of the GRBL environment. Also noted once I accidently tried to add the same controller twice (moving/clicking too fast) and it ended the ability to see or add any controllers. Had to completly remove the software and residual settings then reinstall to clear issue up.