Laser drifting. Bad stepper?

In the picture you can see I am getting drift. Never had this issue before. File is created in Lightburn and ran with Gsender. I also tried running direct from Light burn and got the same thing. Hoping you can help me sort this if it’s software. I am thinking I have a tired stepper motor at this point

1 Like

@Parrott Hello! I will take a stab at it, although I don’t have a laser as of yet, my troubleshooting skills are fairly good. If you tried two softwares with similar or the same results, I would conclude that your issue is not software based. The stepper motor could be weak, or could something be binding on that axis causing your drift. A potential next step is to switch stepper motors with the other side and see if the problem follows the motor or stays similar to the drift you are reporting now. That would or should be the key to finding out the culprit. Let us know how you come out, I’m sure others will have this happen to them eventually.
Take care!

1 Like

It’s dead on consistent. If the Kobe is started over it tracks the same mistake which puts a little hope into it still being something I am missing on the software side

@Parrott I must admit that I am lost when you say “if the kobe is started over it tracks the same”. However, if you post your lbrn file, others hear may be able to run it to see if they get the same results.

Kobe = job lol. I will get the file up shortly.

1 Like

Here is the file.!ApSXmLfmii6ZvF_oiNNl2mmaiUtj?e=5e34G3

Sorry for my ignorance but what does laser drift mean? I tried to look it up and what I found was related to frequency drift but you mention a possible bad stepper and I can’t put that together with ‘frequency drift’. I do see the horizontal line where it is darker on the bottom.

I assume the machine is making horizontal passes moving from bottom to top a little with each pass. So it looks to me like the power, focus or speed changed at or just after the line. Am I thinking along the right lines?

@Parrott I’ve run it in LB preview, so at least now I can see how it supposed to look. :grinning:

What do you have sMax set to in LB, and have you set $30 to the same value? Have you set $32=1?

All settings are at default. Where do I change this? Never had any issues with vcarve pro. Only staring to play with the laser.

@Parrott In LB, go to device settings. You will see a value for Smax. Set it to 1000, if it is not already. Then, close device settings.

In the Window menu item at the top of the screen, make sure that Console is selected. Then click on Reset to Default Layout.

You will now have a tab for Console in your window panels. Click on the Console tab. At the bottom of the main console window, you will see a small window with the greyed text “type command here”. Type $30=1000 and hit enter. Then type $32=1 and hit enter.

Now try your project in LB and report back.

Regardless the outcome, before you exit LB, go back into Console. Type $30=30000 and hit enter. Type $32=0 and hit enter. Then you can exit LB.

There is a pre-programmed way in gSender to set these values for either laser or router. You can read about it in the gSender documentation. (These instructions are also in the LB docs.)

1 Like

Stilling getting the drift with the above recommendation’s. I am really stumped here. Even on a simple material test if drifts

@Parrott Since it sounds like things have worked in the past, first thing to consider is “what changed?”.

It seems to be “drifting” in X. You may want to ensure that the motor coupler is not slipping. Also check the anti-backlash nut on the X lead screw and the delrin wheels on the X gantry.

Try a router file, doing a simple square.

I did have a job pause mid way and then start back up and was offset. If I recall it was not drifting. I am now thinking my firm ware may have gotten corruputed. Going to try flashing it and re running a job. The x axis no mater what speed is off setting from 0 a few mm each pass. Already tried the wheels and other ajustments mech wise. If it does it after the flash I will try changing my X stepper with one of the Y steppers. If its the motor I will have the X issue fixed and see drift in another direction.

1 Like

@gwilki Not having the access to my machine until the weekend to try a flash I have came up with some questions as I rabbit hole deeper and deeper. The laser set up and use seemed very simple with my CNC experience. While trying to solve my current issue I have realized that I cannot just treat the laser like a new bit and run it to its limit just the same. Additional software, movement and timing are now at play. With that said I am about ask some questions that may help me solve this issue and some info does not come across as straight forward as I thought.
Watching one Sienci’s video on “fastmove white space” They said the mill has a max speed of 66mm/min. I have been running at 1800mm/min. Ikeena has his Lightburn job is set at 25mm/min but his Gsender reads the movement at 1500mm/min while running the job.

What am I missing with speed conversions that you are running at 1800mm/min if the max speed is 66mm/min?

I think you may have gotten some of the units wrong.

I’m betting that Ikeena has 25mm/s set in LB because 25 * 60 = 1500mm/min.

1 Like

Where is the x60 coming from? Becuse if that is the case I have LB set at 1800. So would that be 1800x60 causing me to loose steps?

@Parrott I’m quite certain that @_Michael has it right. I believe that you are confusing mm/min and mm/sec. In LB, I suggest that you set your units to mm/min, which is what LB recommends for diode lasers. I don’t know how Ikenna sets his. Neither is right or wrong. However, since Sienci sets their max feed rates in mm/min, it is a good place to start.

In terms of max speeds for the LM, again I have not watched Ikenna’s video. However, the default max settings for the LM are 4000 mm/min in X and Y and 3000 mm/min in Z. You can find those settings here

Some oversight for me to digest. His mm/sec is under the CO2 setting. Still think it is a flash I need I now know to double check the units. :slight_smile:

So I flashed the controller and I and back up and running. Now after doing that I realized I missed a learning moment. Checking all the $$ settings everything there matched the settings in the eeprom link, thank you for that. Is there something else I could have downloaded from controller with more details? Since it’s working great now I would like to get all the details. Then if it happens again I can match the deeper dive to compare and narrow what caused it. Only thing I can think of was I have an offline computer running an old version Lightburn and when the file was loaded to my laptop LB burn gave a warning but that should only effect that one file. Maybe it happed there? Not sure but Thank you everyone For quickly jumping in with some solid support :slight_smile:

@Parrott I don’t believe that there is anything more that you could download that would provide more details of the eeprom settings. However, since all is well now, I will close this thread. If problems arise, do not hesitate to open a new thread with details.

1 Like